summaryrefslogtreecommitdiff
path: root/media-sound/pnmixer/pnmixer-0.7.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-05 04:22:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-05 04:22:44 +0100
commitb89f5897f4301157fb1a4af17e0c941703a2579c (patch)
tree0a89dd05e40af0fbb1612a7666cdc94c7fdbbd15 /media-sound/pnmixer/pnmixer-0.7.2-r1.ebuild
parent16dba5216d31038098e918bd83df2aaa1849d4e9 (diff)
gentoo auto-resync : 05:09:2023 - 04:22:44
Diffstat (limited to 'media-sound/pnmixer/pnmixer-0.7.2-r1.ebuild')
-rw-r--r--media-sound/pnmixer/pnmixer-0.7.2-r1.ebuild17
1 files changed, 4 insertions, 13 deletions
diff --git a/media-sound/pnmixer/pnmixer-0.7.2-r1.ebuild b/media-sound/pnmixer/pnmixer-0.7.2-r1.ebuild
index a76a058cd96f..739d024f7dad 100644
--- a/media-sound/pnmixer/pnmixer-0.7.2-r1.ebuild
+++ b/media-sound/pnmixer/pnmixer-0.7.2-r1.ebuild
@@ -1,14 +1,15 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
MY_P="${PN}-v${PV}"
-inherit cmake xdg-utils
+inherit cmake xdg
DESCRIPTION="Volume mixer for the system tray"
HOMEPAGE="https://github.com/nicklan/pnmixer"
SRC_URI="https://github.com/nicklan/${PN}/releases/download/v${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-3"
SLOT="0"
@@ -32,8 +33,6 @@ BDEPEND="
nls? ( sys-devel/gettext )
"
-S="${WORKDIR}/${MY_P}"
-
PATCHES=(
"${FILESDIR}/${P}-fix-assert-if-volume-gt-100.patch"
"${FILESDIR}/${P}-fix-possible-garbage-value.patch"
@@ -49,11 +48,3 @@ src_configure() {
)
cmake_src_configure
}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}