summaryrefslogtreecommitdiff
path: root/media-sound/pnmixer/pnmixer-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/pnmixer/pnmixer-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/pnmixer/pnmixer-9999.ebuild')
-rw-r--r--media-sound/pnmixer/pnmixer-9999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-sound/pnmixer/pnmixer-9999.ebuild b/media-sound/pnmixer/pnmixer-9999.ebuild
new file mode 100644
index 000000000000..69801bb9225a
--- /dev/null
+++ b/media-sound/pnmixer/pnmixer-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WANT_LIBTOOL=none
+inherit cmake-utils gnome2-utils git-r3
+
+DESCRIPTION="Volume mixer for the system tray"
+HOMEPAGE="https://github.com/nicklan/pnmixer"
+EGIT_REPO_URI="git@github.com:nicklan/pnmixer.git
+ https://github.com/nicklan/pnmixer.git"
+EGIT_BRANCH="master"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="libnotify"
+
+RDEPEND="dev-libs/glib:2
+ media-libs/alsa-lib
+ >=x11-libs/gtk+-3.12:3
+ x11-libs/libX11
+ libnotify? ( x11-libs/libnotify )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_LIBNOTIFY="$(usex libnotify)"
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}