summaryrefslogtreecommitdiff
path: root/media-sound/qjackctl/qjackctl-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /media-sound/qjackctl/qjackctl-9999.ebuild
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'media-sound/qjackctl/qjackctl-9999.ebuild')
-rw-r--r--media-sound/qjackctl/qjackctl-9999.ebuild29
1 files changed, 14 insertions, 15 deletions
diff --git a/media-sound/qjackctl/qjackctl-9999.ebuild b/media-sound/qjackctl/qjackctl-9999.ebuild
index 87c768da8ec4..3d91bddef6f4 100644
--- a/media-sound/qjackctl/qjackctl-9999.ebuild
+++ b/media-sound/qjackctl/qjackctl-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic qmake-utils autotools git-r3 xdg-utils
@@ -12,9 +12,9 @@ EGIT_REPO_URI="https://git.code.sf.net/p/qjackctl/code"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-
IUSE="alsa dbus debug portaudio"
+BDEPEND="dev-qt/linguist-tools:5"
RDEPEND="
app-arch/gzip
dev-qt/qtcore:5
@@ -26,24 +26,23 @@ RDEPEND="
alsa? ( media-libs/alsa-lib )
dbus? ( dev-qt/qtdbus:5 )
portaudio? ( media-libs/portaudio )"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5"
+DEPEND="${RDEPEND}"
src_prepare() {
- eautoreconf
-
default
+ eautoreconf
}
src_configure() {
append-cxxflags -std=c++11
- econf \
- $(use_enable alsa alsa-seq) \
- $(use_enable dbus) \
- $(use_enable debug) \
- $(use_enable portaudio) \
+ local myeconfargs=(
+ $(use_enable alsa alsa-seq)
+ $(use_enable dbus)
+ $(use_enable debug)
+ $(use_enable portaudio)
--enable-jack-version
-
+ )
+ econf "${myeconfargs[@]}"
eqmake5 ${PN}.pro -o ${PN}.mak
}
@@ -54,8 +53,8 @@ src_compile() {
src_install() {
default
- gunzip "${D}/usr/share/man/man1/qjackctl.fr.1.gz"
- gunzip "${D}/usr/share/man/man1/qjackctl.1.gz"
+ gunzip "${D}/usr/share/man/man1/qjackctl.fr.1.gz" || die
+ gunzip "${D}/usr/share/man/man1/qjackctl.1.gz" || die
}
pkg_postinst() {