summaryrefslogtreecommitdiff
path: root/media-sound/quodlibet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-06 08:06:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-06 08:06:16 +0100
commit4187bba080530c5ca1c7dae9c233e88f3fc8f535 (patch)
treeb6f535e053876097ced1b6bda14a4da890c730d4 /media-sound/quodlibet
parent2a8d2f71d1d9963368e0ef3d641d75979a689d12 (diff)
gentoo auto-resync : 06:07:2024 - 08:06:15
Diffstat (limited to 'media-sound/quodlibet')
-rw-r--r--media-sound/quodlibet/Manifest2
-rw-r--r--media-sound/quodlibet/files/quodlibet-4.6.0-python312.patch60
-rw-r--r--media-sound/quodlibet/quodlibet-4.6.0-r2.ebuild61
3 files changed, 123 insertions, 0 deletions
diff --git a/media-sound/quodlibet/Manifest b/media-sound/quodlibet/Manifest
index 346765089a3b..44e3f3a42f5f 100644
--- a/media-sound/quodlibet/Manifest
+++ b/media-sound/quodlibet/Manifest
@@ -1,3 +1,5 @@
+AUX quodlibet-4.6.0-python312.patch 2043 BLAKE2B 2e16a55b6fedad118453fd959a5da2b27afcc79b77fdfbe8796aa92f24eb2602ca003f6874852f5ab04a22716d02156a6b6abba660537c3c893dfcff35b5fe37 SHA512 842aed1afdc1071d37cec2cc23ebd55fe49bd55f3c29c27702cb7329f26f9a18db9724d05cdf59fbcb790e160b7a532ad0fad43c1a29f5be3334c59b6e76ba38
DIST quodlibet-4.6.0.tar.gz 5719390 BLAKE2B 3b5d43c2fc1e5c3dabdf17c1d35f42762f9db4849a2e99e69a261bc72d5af6f0edac56a1f0e888989a839a4fa905209384b1e37a624676e1c52ca7a5d33ce53c SHA512 eb3bae6eaa2b976bce11ded1a521dc3f2a0a83358ae53215d3f5bce82447f721e7fef2e05b5d1ba87ac984c176e52d7915c4d40b529394d8616d846b78a2af8c
EBUILD quodlibet-4.6.0-r1.ebuild 1509 BLAKE2B 48b3944555c6e82b3d2a26519ca6306899a790bee01c9db0e5f5da5c466b9175b6eb3712908d5dcf33d4d2b5ff3fc0040f13e86b2f6c79a70925b90e4d0a567c SHA512 821bc52a4d83e409b94c0932f9374260216281c11685da19bb267af7b9eda9d69aff6e6602add705fec356afd17af7958a455a48a9f11b75aace5f2065c46b29
+EBUILD quodlibet-4.6.0-r2.ebuild 1573 BLAKE2B aad42b992f3f7e1f72ff621c7b89f09c23c88bf9ae9473c69ddc3d42e75a62458ce4be833008f8a3eb182c331bb9c9f4225f7d99a26a35f331f1a60ccf86a9e9 SHA512 87ce368d7009c271fd3b6f0aff6e67fd34c528a3deaae8d10b08bf048d8d13d6460d2a30bd3f5e11744a0d97a31404a8a5656b450c10237691fdda5e2ed7032d
MISC metadata.xml 799 BLAKE2B 364d6668369b9ffb420a6adc0515756b917ab113682a8fdf4dce577c5d046b3a32ebfd0ae5961df0f84b3a3f398a2d0a054b92fff028e6e738e46d306caafc65 SHA512 2370a1cb76093d2dec8e3f77b4fb4fd1966cbdf97016f7b7125fc8c774a9d902f88fa5e56cbcf8b08c9015a0505eed508246d6fc967b732bc2a50f01dcfcbc02
diff --git a/media-sound/quodlibet/files/quodlibet-4.6.0-python312.patch b/media-sound/quodlibet/files/quodlibet-4.6.0-python312.patch
new file mode 100644
index 000000000000..da781fd35523
--- /dev/null
+++ b/media-sound/quodlibet/files/quodlibet-4.6.0-python312.patch
@@ -0,0 +1,60 @@
+From a8b6f6bb34864a6821174edbf7802b689e440db3 Mon Sep 17 00:00:00 2001
+From: LuK1337 <priv.luk@gmail.com>
+Date: Wed, 23 Aug 2023 17:13:23 +0200
+Subject: [PATCH] Fix startup on Python 3.12
+
+--- a/quodlibet/_import.py
++++ b/quodlibet/_import.py
+@@ -8,6 +8,7 @@
+
+ import sys
+ import importlib
++import importlib.util
+
+
+ class RedirectImportHook:
+@@ -31,6 +32,11 @@ def __init__(self, name, packages):
+ self._name = name
+ self._packages = packages
+
++ def find_spec(self, fullname, path, target=None):
++ loader = self.find_module(fullname, path)
++ if loader is not None:
++ return importlib.util.spec_from_loader(fullname, loader)
++
+ def find_module(self, fullname, path=None):
+ package = fullname.split(".")[0]
+ if package in self._packages:
+--- a/quodlibet/util/config.py
++++ b/quodlibet/util/config.py
+@@ -377,7 +377,7 @@ def read(self, filename):
+ with open(filename, "rb") as fileobj:
+ fileobj = StringIO(
+ fileobj.read().decode("utf-8", "surrogateescape"))
+- self._config.readfp(fileobj, filename)
++ self._config.read_file(fileobj, filename)
+ except (IOError, OSError):
+ return
+
+--- a/quodlibet/util/importhelper.py
++++ b/quodlibet/util/importhelper.py
+@@ -92,8 +92,8 @@ def load_module(name, package, path):
+ except KeyError:
+ pass
+
+- loader = importlib.find_loader(fullname, [path])
+- if loader is None:
++ spec = importlib.machinery.PathFinder.find_spec(fullname, [path])
++ if spec is None:
+ return
+
+ # modules need a parent package
+@@ -101,7 +101,7 @@ def load_module(name, package, path):
+ spec = importlib.machinery.ModuleSpec(package, None, is_package=True)
+ sys.modules[package] = importlib.util.module_from_spec(spec)
+
+- mod = loader.load_module(fullname)
++ mod = spec.loader.load_module(fullname)
+
+ # make it accessible from the parent, like __import__ does
+ vars(sys.modules[package])[name] = mod
diff --git a/media-sound/quodlibet/quodlibet-4.6.0-r2.ebuild b/media-sound/quodlibet/quodlibet-4.6.0-r2.ebuild
new file mode 100644
index 000000000000..66f6d813cb08
--- /dev/null
+++ b/media-sound/quodlibet/quodlibet-4.6.0-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 xdg
+
+DESCRIPTION="audio library tagger, manager, and player for GTK+"
+HOMEPAGE="https://quodlibet.readthedocs.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/${PN}-release-${PV}"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+dbus gstreamer +udev"
+
+RDEPEND="dev-libs/keybinder:3[introspection]
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ media-libs/mutagen[${PYTHON_USEDEP}]
+ net-libs/libsoup:3.0[introspection]
+ x11-libs/gtk+[introspection]
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ media-plugins/gst-plugins-meta:1.0
+ )
+ !gstreamer? ( media-libs/xine-lib )
+ dbus? (
+ app-misc/media-player-info
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ )
+ udev? ( virtual/udev )"
+DEPEND="dev-util/intltool"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.6.0-python312.patch"
+)
+
+src_prepare() {
+ local qlconfig=quodlibet/config.py
+
+ if ! use gstreamer; then
+ sed -i -e '/backend/s:gstbe:xinebe:' ${qlconfig} || die
+ fi
+
+ sed -i -e '/gst_pipeline/s:"":"alsasink":' ${qlconfig} || die
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc README.rst
+
+ # fix location of desktop file
+ mv "${ED}/usr/share/appdata" "${ED}/usr/share/metainfo" || die "Failed to fix desktop file location"
+}