summaryrefslogtreecommitdiff
path: root/media-sound/shntool/shntool-3.0.10-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-14 11:10:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-14 11:10:11 +0100
commit81b8f20732954c4508baf2f77472b5435e3f851f (patch)
tree4180177cb7ba85eab50159ce96218c2419fb24a6 /media-sound/shntool/shntool-3.0.10-r2.ebuild
parent946859e0e36904cffb3e0ccbccb6b7b1347c1cc8 (diff)
gentoo auto-resync : 14:09:2022 - 11:10:10
Diffstat (limited to 'media-sound/shntool/shntool-3.0.10-r2.ebuild')
-rw-r--r--media-sound/shntool/shntool-3.0.10-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-sound/shntool/shntool-3.0.10-r2.ebuild b/media-sound/shntool/shntool-3.0.10-r2.ebuild
new file mode 100644
index 000000000000..fb803b412363
--- /dev/null
+++ b/media-sound/shntool/shntool-3.0.10-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A multi-purpose WAVE data processing and reporting utility"
+HOMEPAGE="http://www.etree.org/shnutils/shntool/"
+SRC_URI="http://www.etree.org/shnutils/shntool/dist/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="alac flac mac shorten sox wavpack"
+
+RDEPEND="
+ alac? ( media-sound/alac_decoder )
+ flac? ( media-libs/flac )
+ mac? ( media-sound/mac )
+ shorten? ( media-sound/shorten )
+ sox? ( media-sound/sox )
+ wavpack? ( media-sound/wavpack )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ export CONFIG_SHELL=${BASH} # bug #527310
+ default
+}
+
+src_install() {
+ default
+ dodoc -r doc/.
+}