summaryrefslogtreecommitdiff
path: root/media-sound/solfege/solfege-3.22.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/solfege/solfege-3.22.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/solfege/solfege-3.22.2.ebuild')
-rw-r--r--media-sound/solfege/solfege-3.22.2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/media-sound/solfege/solfege-3.22.2.ebuild b/media-sound/solfege/solfege-3.22.2.ebuild
new file mode 100644
index 000000000000..4b2a288d34e1
--- /dev/null
+++ b/media-sound/solfege/solfege-3.22.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit python-single-r1
+
+DESCRIPTION="GNU Solfege is a program written to help you practice ear training"
+HOMEPAGE="https://www.gnu.org/software/solfege/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="alsa oss"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-python/pygtk-2.12
+ gnome-base/librsvg
+ alsa? ( dev-python/pyalsa )
+ !oss? ( media-sound/timidity++ )"
+DEPEND="${PYTHON_DEPS}
+ dev-lang/swig
+ sys-devel/gettext
+ sys-apps/texinfo
+ virtual/pkgconfig
+ dev-libs/libxslt
+ app-text/txt2man
+ >=app-text/docbook-xsl-stylesheets-1.60"
+
+RESTRICT="test"
+
+src_prepare() {
+ sed -i -e '/^CFLAGS/s:-I/usr/src/linux/include::' \
+ solfege/soundcard/Makefile || die
+}
+
+src_configure() {
+ local xslloc=$( xmlcatalog /etc/xml/catalog http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl | sed 's@file://@@' )
+
+ econf \
+ --enable-docbook-stylesheet=${xslloc} \
+ $(use_enable oss oss-sound)
+}
+
+src_compile() {
+ emake skipmanual=yes
+}
+
+src_install() {
+ emake DESTDIR="${ED}" nopycompile=YES skipmanual=yes install
+ dodoc AUTHORS *hange*og FAQ README
+}