summaryrefslogtreecommitdiff
path: root/media-sound/soundconverter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-17 00:09:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-17 00:09:46 +0100
commit74e526c590f52d24a213e25f77858ae0b34ec2c8 (patch)
tree0f6f22133ae9cc04958f6df6d39a02d90ffb1aaf /media-sound/soundconverter
parent0a3feeaba4dbc58966dccdbbfcd7fb14deef0831 (diff)
gentoo auto-resync : 17:06:2024 - 00:09:46
Diffstat (limited to 'media-sound/soundconverter')
-rw-r--r--media-sound/soundconverter/Manifest4
-rw-r--r--media-sound/soundconverter/soundconverter-4.0.3.ebuild4
-rw-r--r--media-sound/soundconverter/soundconverter-4.0.5.ebuild100
3 files changed, 105 insertions, 3 deletions
diff --git a/media-sound/soundconverter/Manifest b/media-sound/soundconverter/Manifest
index 20bccc6213cc..66f9a8198163 100644
--- a/media-sound/soundconverter/Manifest
+++ b/media-sound/soundconverter/Manifest
@@ -1,3 +1,5 @@
DIST soundconverter-4.0.3.gh.tar.gz 632495 BLAKE2B 9a2847b5ebb998b9122ff4020e47dc5b84635a6e1ae0de9061bab18e813ab3918278e940df80bc370b071de77a82a3637c376d9ebdd84d2f7b00865dda94935a SHA512 0674eb430bb3cf267ceabee8e7dbdeb2ee81e537ca093fcf6e1adab21112690ed9e3eb349a994805ddfc51b3a4f875b87a5819a1f2cf020752eb8e742665a998
-EBUILD soundconverter-4.0.3.ebuild 2754 BLAKE2B 486029378330683c9c482f4de77253b2a066e8fc6fb0f8888fc643c5fd62a772c242e5b2a23b4b5f3512c5fe09920a1ca3f9d4f0320b84d3a74f67afb1e52313 SHA512 68f94985291e47af01dcfc4598cf6fecfa056a9cc4bd91c05ae065b58ebdd3c3c9a26b54d40631eca6998fb119f145e73800f3b2b1363909355c4e7bd8323d41
+DIST soundconverter-4.0.5.gh.tar.gz 638789 BLAKE2B e4cb89b9911d7f28e3db2b5e93858defc4ac12199805a61aa74264a89bc81037a6597ee404d84881ff83af33b59bc64a8267b682e3cba4109ddc1e4a3798f90d SHA512 efd96fcf1f75381c985cbc7cc849462fc424e7b54fcbbb5e63e49e32b195dfab43806fecbc4e7f9a7f70b0df4e9a6d511b07dcaaca5eaa5e29bc49e1e66acb4b
+EBUILD soundconverter-4.0.3.ebuild 2754 BLAKE2B 91e1914ab0329ca75f5e9ab451523ecad425afce1e32d42940162fea37c84746ef2ee72413c43a040073720b26747e67c5e7503223b7075681c1bceea6789610 SHA512 53b510d436b42804ab58fa9cddaab9aa220ab0aa36d9ae795a8d6461a564f0388d5591ef5aba254664d3494f2911ec4c55f38b4c65aad3563ed98495f2bf1617
+EBUILD soundconverter-4.0.5.ebuild 2756 BLAKE2B aecf99b7adfbbbdbeb792c5c448ad541c0093f1cd5eb28f10a4909d55a7fbc259a6e077329f20e86053d1928737896a0b4dd223fa0395947e6d8e68baa03c326 SHA512 fa8b22dcc46e0b826714aa3a1b1732aa3415e6aade0fd9f032ffe3fbcefc99b409cfb638508414a6c13c5ba7fbe7ca756a418647535f634cd507a8fe1ed55e50
MISC metadata.xml 413 BLAKE2B b72915536e7a83e087d9fbe87756b3a8ffa38265360d17bfacaadf75694a032bf55b024574813692ff91e0664ab0849584ab3027e277443260ff9a3afc31ffa4 SHA512 772a3ec6f12308dea14140a65e35c66066e7f9869e1518f92313f23f46f2a6f7b3f18f3b2650c7197c934d07219bca656c446aae7ef7532b57323f924222939e
diff --git a/media-sound/soundconverter/soundconverter-4.0.3.ebuild b/media-sound/soundconverter/soundconverter-4.0.3.ebuild
index 3385a3f88ae1..a9c9d60dae78 100644
--- a/media-sound/soundconverter/soundconverter-4.0.3.ebuild
+++ b/media-sound/soundconverter/soundconverter-4.0.3.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="xml(+)"
inherit gnome2-utils distutils-r1 virtualx xdg
diff --git a/media-sound/soundconverter/soundconverter-4.0.5.ebuild b/media-sound/soundconverter/soundconverter-4.0.5.ebuild
new file mode 100644
index 000000000000..b4704cea2c49
--- /dev/null
+++ b/media-sound/soundconverter/soundconverter-4.0.5.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+inherit gnome2-utils distutils-r1 virtualx xdg
+
+MY_PV="${PV/_/-}"
+DESCRIPTION="A simple audiofile converter application for the GNOME environment"
+HOMEPAGE="https://soundconverter.org/"
+SRC_URI="https://github.com/kassoulet/${PN}/archive/${MY_PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="aac flac mp3 ogg opus vorbis"
+
+# gst-plugins-meta for any decoders, USE flags for specific encoders used by code
+# List in soundconverter/gstreamer.py
+# wavenc and mp4mux come from gst-plugins-good, which everyone having base should have, so unconditional
+RDEPEND="
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-libs/pango[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ ')
+ media-libs/gst-plugins-base:1.0[vorbis?,ogg?]
+ media-plugins/gst-plugins-meta:1.0
+ flac? ( media-plugins/gst-plugins-flac:1.0 )
+ media-libs/gst-plugins-good:1.0
+ mp3? (
+ media-libs/gst-plugins-bad:1.0
+ media-libs/gst-plugins-ugly:1.0
+ media-plugins/gst-plugins-lame:1.0
+ )
+ aac? ( media-plugins/gst-plugins-faac:1.0 )
+ opus? ( media-plugins/gst-plugins-opus:1.0 )
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ ')
+ dev-util/intltool
+ test? (
+ media-plugins/gst-plugins-flac:1.0
+ media-libs/gst-plugins-bad:1.0
+ media-libs/gst-plugins-ugly:1.0
+ media-plugins/gst-plugins-lame:1.0
+ media-plugins/gst-plugins-faac:1.0
+ media-plugins/gst-plugins-opus:1.0
+ )
+"
+
+# Before PEP517: tests seem to hang and also fail to find fdkaacenc from gst?
+# After: need to trick it into finding the data (inc. glade files)
+RESTRICT="test"
+
+python_prepare_all() {
+ gnome2_environment_reset
+ distutils-r1_python_prepare_all
+
+ rm -v "${S}/CHANGELOG.old" || die
+
+ # workaround incorrect behavior when LINGUAS is set to an empty string
+ # https://bugs.launchpad.net/python-distutils-extra/+bug/1133594
+ ! [[ -v LINGUAS && -z ${LINGUAS} ]] || rm po/*.po || die
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ export GSETTINGS_SCHEMA_DIR="${S}/data"
+ "${BROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}"/data || die
+
+ "${EPYTHON}" tests/test.py || die
+}
+
+python_install_all() {
+ rm -v "${ED}"/usr/share/glib-2.0/schemas/gschemas.compiled || die
+ mv -v "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${PF} || die
+ distutils-r1_python_install_all
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}