summaryrefslogtreecommitdiff
path: root/media-sound/sox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-10 21:02:07 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-10 21:02:07 +0000
commit0ca3f86640e2f1f361da895b997c43bac22090a1 (patch)
tree029b42e7b1425ce16f4299635e5caad713501ead /media-sound/sox
parentbe94ae04eee564451203d45977c2ef7c7ace1580 (diff)
gentoo auto-resync : 10:11:2024 - 21:02:06
Diffstat (limited to 'media-sound/sox')
-rw-r--r--media-sound/sox/Manifest2
-rw-r--r--media-sound/sox/sox-14.4.2_p20210509-r3.ebuild116
2 files changed, 118 insertions, 0 deletions
diff --git a/media-sound/sox/Manifest b/media-sound/sox/Manifest
index c7380d05fbcf..afe01dfc2072 100644
--- a/media-sound/sox/Manifest
+++ b/media-sound/sox/Manifest
@@ -1,3 +1,5 @@
+DIST sox-14.4.2_p20210509-patchset.tar.xz 3560 BLAKE2B 8f575dbff121d749c83c6074dadeb92475472f36ad5b9c389e1591b60cff853167c22f7c059731fa5b78c497817bcae6be93ace21bfe605faf2445301a0fe2af SHA512 4b57689bc85ac7664693c6344fd17c7fc7991e04d5e6628c2455c8e541ecfec073690d4dc23a909474ba93fd24cd877aa77f1e7fcc5b52773daa794689212bb8
DIST sox-14.4.2_p20210509.zip 942551 BLAKE2B 2ddd229faacb9190fe18052b1c02da40d4c3f24fc73dd08b28ac99bef267cb05f8bcbf64e0c397c391b3be2467667783ed94f6c60798af069567e1c237ec9ccd SHA512 4868f9b77141b7e2caf2571ceb68a48bd744732e72f63ed787f8e0b9fe39b77de4e998b32d99c2500e10b017a1fd1a3379f4f9f8b67db6093b85d02cb3447934
EBUILD sox-14.4.2_p20210509-r2.ebuild 2822 BLAKE2B a92c404134cb89b8d4405f4ae6d202079ee17412e25eadb445929fd6a73b85106fe9b9cde4490808c079fcd67eee4238b7af47d4a2d12ec5b24fa427f7ec34f1 SHA512 55f1882b23db68ab9a1bdbe7ccdc23feeacfce19688fdbd2aa11951e6fdbb404772e39572cf059031dbc21d5d4c656ff1ba482834cd6c655f4f48dd4e8957cee
+EBUILD sox-14.4.2_p20210509-r3.ebuild 2878 BLAKE2B 20dfb582aca454d27edb7e6384afd944093476edc2cc8d3045794132b793b993aa70dd46cd61d8fb667a7b2d5b1f1818aebccfb1f0878f88c047e2340f1306af SHA512 4204a3c684db0e5906e62373aa7d4421c921f72e2bcb4198b14d4e98a4885519e07cac5a97ae04ba704df94b5f22b7209fc0190e58b02c03cf36bac5d46fbf0b
MISC metadata.xml 709 BLAKE2B 29d863a59fa534ccdaf3ccfe73ec03ff931055b7537ce3ef1111a596c8178f944910cd3c917e25f778a1e297d5fd0023833d0a8556adb6cd187fbd59e2ff5703 SHA512 a40c70b421b78a8bf2b7044b1b512600120c0352bf61755ba7d48af621fcc33c82ef3c7eff3df10c913add4b7250f7fb7461ea7171b21a07f306794d7c1cbdbf
diff --git a/media-sound/sox/sox-14.4.2_p20210509-r3.ebuild b/media-sound/sox/sox-14.4.2_p20210509-r3.ebuild
new file mode 100644
index 000000000000..760e1809a0d3
--- /dev/null
+++ b/media-sound/sox/sox-14.4.2_p20210509-r3.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+# We take a snapshot because of the huge number of security
+# and other fixes since the release of 14.4.2.
+# Recommend mirroring the snapshot; unclear if they are stable URIs.
+COMMIT="42b3557e13e0fe01a83465b672d89faddbe65f49"
+MY_P="sox-code-${COMMIT}"
+
+PATCHSET="${P}-patchset"
+
+DESCRIPTION="The swiss army knife of sound processing programs"
+HOMEPAGE="https://sox.sourceforge.net"
+# Source: https://sourceforge.net/code-snapshots/git/s/so/sox/code.git/${MY_P}.zip
+SRC_URI="https://dev.gentoo.org/~fordfrog/distfiles/${MY_P}.zip -> ${P}.zip
+ https://dev.gentoo.org/~asturm/distfiles/${PATCHSET}.tar.xz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="alsa amr ao encode flac id3tag ladspa mad ogg openmp oss opus png pulseaudio sndfile sndio twolame wavpack"
+
+RDEPEND="
+ dev-libs/libltdl:0=
+ >=media-sound/gsm-1.0.12-r1
+ sys-apps/file
+ alsa? ( media-libs/alsa-lib )
+ amr? ( media-libs/opencore-amr )
+ ao? ( media-libs/libao:= )
+ encode? ( >=media-sound/lame-3.98.4 )
+ flac? ( >=media-libs/flac-1.1.3:= )
+ id3tag? ( media-libs/libid3tag:= )
+ ladspa? ( media-libs/ladspa-sdk )
+ mad? ( media-libs/libmad )
+ ogg? (
+ media-libs/libogg
+ media-libs/libvorbis
+ )
+ opus? (
+ media-libs/opus
+ media-libs/opusfile
+ )
+ png? (
+ media-libs/libpng:0=
+ sys-libs/zlib
+ )
+ pulseaudio? ( media-libs/libpulse )
+ sndfile? ( >=media-libs/libsndfile-1.0.11 )
+ sndio? ( media-sound/sndio:= )
+ twolame? ( media-sound/twolame )
+ wavpack? ( media-sound/wavpack )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/unzip
+ dev-build/autoconf-archive
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog NEWS )
+
+PATCHES=( "${WORKDIR}/${PATCHSET}" ) # bug 838382
+
+src_prepare() {
+ default
+
+ # bug #386027
+ sed -i -e 's|CFLAGS="-g"|CFLAGS="$CFLAGS -g"|' configure.ac || die
+
+ # bug #712630
+ if use elibc_musl ; then
+ ewarn "Applying musl workaround for bug #712630."
+ ewarn "File-type detection with pipes may be missing."
+ sed -i '/error FIX NEEDED HERE/d' src/formats.c || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable alsa)
+ $(use_enable amr amrnb)
+ $(use_enable amr amrwb)
+ $(use_enable ao)
+ $(use_with encode lame)
+ $(use_enable flac)
+ $(use_with id3tag)
+ $(use_with ladspa ladspa dyn)
+ $(use_with mad)
+ --with-magic
+ $(use_enable openmp)
+ $(use_enable ogg oggvorbis)
+ $(use_enable oss)
+ $(use_enable opus)
+ $(use_with png)
+ $(use_enable pulseaudio)
+ $(use_enable sndfile)
+ $(use_enable sndio)
+ $(use_with twolame)
+ $(use_enable wavpack)
+ --enable-formats=dyn
+ --with-distro="Gentoo"
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}