summaryrefslogtreecommitdiff
path: root/media-sound/specimen/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /media-sound/specimen/files
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'media-sound/specimen/files')
-rw-r--r--media-sound/specimen/files/specimen-0.5.2_rc3-jackmidi.patch22
-rw-r--r--media-sound/specimen/files/specimen-0.5.2_rc3-underlinking.patch93
2 files changed, 0 insertions, 115 deletions
diff --git a/media-sound/specimen/files/specimen-0.5.2_rc3-jackmidi.patch b/media-sound/specimen/files/specimen-0.5.2_rc3-jackmidi.patch
deleted file mode 100644
index 2e3cf2ba9125..000000000000
--- a/media-sound/specimen/files/specimen-0.5.2_rc3-jackmidi.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Index: specimen-0.5.2-rc3/src/jackdriver.c
-===================================================================
---- specimen-0.5.2-rc3.orig/src/jackdriver.c
-+++ specimen-0.5.2-rc3/src/jackdriver.c
-@@ -81,7 +81,7 @@ static int process (jack_nframes_t frame
- jack_midi_event_t jack_midi_event;
- jack_nframes_t event_index = 0;
- #ifdef HAVE_JACK_MIDI
-- jack_nframes_t event_count = jack_midi_get_event_count(midi_buf, frames);
-+ jack_nframes_t event_count = jack_midi_get_event_count(midi_buf);
- #endif /* HAVE_JACK_MIDI */
- #ifdef HAVE_OLD_JACK_MIDI
- jack_nframes_t event_count = jack_midi_port_get_info(midi_buf, frames)->event_count;
-@@ -123,7 +123,7 @@ static int process (jack_nframes_t frame
- /* send the JACK MIDI events to the mixer */
- while (event_index < event_count) {
-
-- jack_midi_event_get(&jack_midi_event, midi_buf,event_index, frames);
-+ jack_midi_event_get(&jack_midi_event, midi_buf,event_index);
- midi_data = jack_midi_event.buffer;
-
- /* TODO: handle 14-bit controllers and RPNs and NRPNs */
diff --git a/media-sound/specimen/files/specimen-0.5.2_rc3-underlinking.patch b/media-sound/specimen/files/specimen-0.5.2_rc3-underlinking.patch
deleted file mode 100644
index db0df85debd7..000000000000
--- a/media-sound/specimen/files/specimen-0.5.2_rc3-underlinking.patch
+++ /dev/null
@@ -1,93 +0,0 @@
-* Remove hardcoded CFLAGS
-* Fix underlinking issues
- - missing -lm linkage (sin)
- - missing -pthread linkage
- -> https://bugs.gentoo.org/show_bug.cgi?id=561562
-
---- specimen-0.5.2-rc3/configure.ac
-+++ specimen-0.5.2-rc3/configure.ac
-@@ -1,10 +1,10 @@
- # -*- autoconf -*-
- # Process this file with autoconf to produce a configure script.
-
--AC_INIT(configure.ac)
--AM_INIT_AUTOMAKE(specimen, 0.5.2-rc3)
--AM_CONFIG_HEADER(src/config.h)
--
-+AC_INIT([specimen], [0.5.2-rc3])
-+AC_CONFIG_HEADERS([src/config.h])
-+AM_INIT_AUTOMAKE
-+m4_include([acx_pthread.m4])
-
- # compilation
- with_debug="no"
-@@ -13,9 +13,7 @@
- [enable debugging information, accepting a performance penalty (default is NO)])],
- [if test x$enable_debug = xyes; then with_debug=yes ; fi])
-
--if test x$with_debug = xno; then
-- CFLAGS="-O3"
--else
-+if test x$with_debug = xyes; then
- AC_DEFINE(DEBUG, 1, [[whether to display debugging output or not]])
- fi
-
-@@ -48,13 +46,14 @@
- AC_FUNC_MALLOC
- AC_CHECK_FUNCS([floor gettimeofday pow strchr strdup])
-
-+dnl Check for libm for sin()
-+AC_SEARCH_LIBS([sin], [m], [], [
-+ AC_MSG_ERROR([unable to find the sin() function])
-+])
-+
- # pthreads
- ACX_PTHREAD
-
--SPECIMEN_CFLAGS="-Wall -Werror"
--AC_SUBST(SPECIMEN_CFLAGS)
--CFLAGS="$SPECIMEN_CFLAGS $CFLAGS"
--
- config_error="no"
-
- # gtk
-@@ -122,7 +121,8 @@
- fi
- fi
-
--CC="$PTHREAD_CC"
-+CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
-+LIBS="$LIBS $PTHREAD_CFLAGS"
-
- # print build summary
- AC_CONFIG_COMMANDS_POST([
---- specimen-0.5.2-rc3/src/gui/Makefile.am
-+++ specimen-0.5.2-rc3/src/gui/Makefile.am
-@@ -12,14 +12,14 @@
- paramselector.c paramselector.h patchlist.c patchlist.h midisection.c \
- midisection.h channelsection.c channelsection.h
-
--INCLUDES = \
-+AM_CPPFLAGS = \
- -l.. \
- @GTK_CFLAGS@ \
- @LIBGNOMECANVAS_CFLAGS@ \
- @PHAT_CFLAGS@
-
- if HAVE_LASH
--INCLUDES += @LASH_CFLAGS@
-+AM_CPPFLAGS += @LASH_CFLAGS@
- endif
-
- libgui_a_CFLAGS = $(CFLAGS) -I.. -DINSTALLDIR=\"$(datadir)\"
---- specimen-0.5.2-rc3/src/Makefile.am
-+++ specimen-0.5.2-rc3/src/Makefile.am
-@@ -11,7 +11,7 @@
- specimen_SOURCES += lashdriver.c lashdriver.h
- endif
-
--INCLUDES = \
-+AM_CPPFLAGS = \
- @ALSA_CFLAGS@ \
- @JACK_CFLAGS@ \
- @LIBSAMPLERATE_CFLAGS@ \