summaryrefslogtreecommitdiff
path: root/media-sound/spotify-tray/spotify-tray-1.3.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
commitc3bc61051d7f12b4c682efa7a5460bbc8815649e (patch)
treeb6d19e96ba3c397fb8278eeb9b68170db92630ba /media-sound/spotify-tray/spotify-tray-1.3.2-r1.ebuild
parent3517852e3b8a68d1e997770fc0650c5053bafc6c (diff)
gentoo resync : 07.01.2022
Diffstat (limited to 'media-sound/spotify-tray/spotify-tray-1.3.2-r1.ebuild')
-rw-r--r--media-sound/spotify-tray/spotify-tray-1.3.2-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-sound/spotify-tray/spotify-tray-1.3.2-r1.ebuild b/media-sound/spotify-tray/spotify-tray-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..dc3be566510a
--- /dev/null
+++ b/media-sound/spotify-tray/spotify-tray-1.3.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools xdg
+
+DESCRIPTION="Wrapper around the Spotify client that adds a tray icon"
+HOMEPAGE="https://github.com/tsmetana/spotify-tray"
+SRC_URI="https://github.com/tsmetana/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="
+ x11-libs/gtk+:3[X]
+"
+RDEPEND="${DEPEND}
+ media-sound/spotify
+"
+
+src_prepare() {
+ default
+ # Fix error: AM_INIT_AUTOMAKE expanded multiple times
+ sed -i -e '/^AM_INIT_AUTOMAKE$/d' configure.ac || die
+
+ # Fix the name of the icon
+ sed -i -e 's/Icon=spotify/Icon=spotify-client/g' spotify-tray.desktop.in || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ # remove desktop file, launching is handled in spotify ebuild
+ rm "${ED}/usr/share/applications/spotify-tray.desktop" || die
+}