summaryrefslogtreecommitdiff
path: root/media-sound/timidity++/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /media-sound/timidity++/files
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'media-sound/timidity++/files')
-rw-r--r--media-sound/timidity++/files/timidity++-2.14.0-gcc5.patch31
-rw-r--r--media-sound/timidity++/files/timidity++-2.14.0-pkg-config.patch109
-rw-r--r--media-sound/timidity++/files/timidity++-2.14.0-revert-for-required-ctl_speana_data-function.patch28
-rw-r--r--media-sound/timidity++/files/timidity++-2.14.0-tcltk86.patch13
4 files changed, 0 insertions, 181 deletions
diff --git a/media-sound/timidity++/files/timidity++-2.14.0-gcc5.patch b/media-sound/timidity++/files/timidity++-2.14.0-gcc5.patch
deleted file mode 100644
index 50d64e3bcbb5..000000000000
--- a/media-sound/timidity++/files/timidity++-2.14.0-gcc5.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Upstream commit 6e189f6073e979ceccaf05c3bb5f495a1b9ed87e
-
-inline, defaults to "extern inline" with newer gcc versions
-
-With newer versions of gcc, "inline" defaults to extern, and not static if
-not specified. This causes linking problems at the end of the compile. Most
-of this occurences are fixed (or #ifdef'ed away) except these two small
-ones in timidity/mfi.c
-
-Signed-off-by: Stian Skjelstad <stian.skjelstad@...>
-
---- a/timidity/mfi.c 2004-02-17 17:02:18.000000000 +0100
-+++ b/timidity/mfi.c 2017-02-14 04:41:24.000000000 +0100
-@@ -344,7 +344,7 @@
- #define SEND_LASTNOTEINFO(lni, ch) if (LASTNOTEINFO_HAS_DATA((lni)[ch])) SendLastNoteInfo(lni, ch);
- #define SEND_AND_CLEAR_LASTNOTEINFO(lni, ch) if (LASTNOTEINFO_HAS_DATA((lni)[ch])) { SendLastNoteInfo(lni, ch); (lni)[ch].on = NO_LAST_NOTE_INFO; }
-
--inline void StoreLastNoteInfo(LastNoteInfo *info, int channel, int time, int duration, int note, int velocity)
-+static inline void StoreLastNoteInfo(LastNoteInfo *info, int channel, int time, int duration, int note, int velocity)
- {
- info[channel].on = time;
- info[channel].off = time + duration;
-@@ -352,7 +352,7 @@
- info[channel].velocity = velocity;
- }
-
--inline void SendLastNoteInfo(const LastNoteInfo *info, int channel)
-+static inline void SendLastNoteInfo(const LastNoteInfo *info, int channel)
- {
- NOTE_BUF_EV_DEBUGSTR(channel, info[channel].on, note_name[info[channel].note % 12], info[channel].note / 12, info[channel].velocity, info[channel].off);
- MIDIEVENT(info[channel].on, ME_NOTEON, channel, info[channel].note, info[channel].velocity);
diff --git a/media-sound/timidity++/files/timidity++-2.14.0-pkg-config.patch b/media-sound/timidity++/files/timidity++-2.14.0-pkg-config.patch
deleted file mode 100644
index 15d6a4ec43f4..000000000000
--- a/media-sound/timidity++/files/timidity++-2.14.0-pkg-config.patch
+++ /dev/null
@@ -1,109 +0,0 @@
-use $PKG_CONFIG rather than `pkg-config`
-
-https://bugs.gentoo.org/497362
-get ncurses info via pkg-config while we're at it
-
-patch by Mike Frysinger <vapier@gentoo.org>
-
---- a/configure.in
-+++ b/configure.in
-@@ -148,6 +148,7 @@ AC_SUBST(xawresdir)
-
- # Checks for programs.
- AM_PATH_LISPDIR
-+PKG_PROG_PKG_CONFIG
- AC_PROG_CC
- AC_PROG_GCC_TRADITIONAL
- AC_PROG_INSTALL
-@@ -1318,8 +1319,8 @@ AC_MSG_CHECKING(enable_audio=jack)
- if test "x$au_enable_jack" = xyes; then
- AC_MSG_RESULT(yes)
- SYSEXTRAS="$SYSEXTRAS jack_a.c"
-- EXTRALIBS="$EXTRALIBS $(pkg-config --libs jack)"
-- EXTRADEFS="$EXTRADEFS -DAU_JACK $(pkg-config --cflags jack)"
-+ EXTRALIBS="$EXTRALIBS $(${PKG_CONFIG} --libs jack)"
-+ EXTRADEFS="$EXTRADEFS -DAU_JACK $(${PKG_CONFIG} --cflags jack)"
- else
- AC_MSG_RESULT(no)
- fi
-@@ -1635,60 +1636,8 @@ dnl ncurses
- AM_CONDITIONAL(ENABLE_NCURSES, false)
- CONFIG_INTERFACE(ncurses,NCURSES,n,
- AS_HELP_STRING([--enable-ncurses], [Enable ncurses interface (default is no)]),
-- [ AC_CHECK_HEADERS(ncurses.h ncurses/curses.h curses.h)
--
--dnl #include <ncurses/curses.h> is failure on Plamo Linux 1.3/ncurses 1.9.9e
--dnl because <ncurses/curses.h> includes <unctrl.h>:
--dnl /usr/include/ncurses/curses.h:34: unctrl.h: No such file or directory
--dnl But surely there is unctl.h at /usr/include/ncurses/unctrl.h.
--dnl configure must check ncurses header with -I/usr/include/ncurses option.
--
-- case "$ac_cv_header_curses_h$ac_cv_header_ncurses_curses_h$ac_cv_header_ncurses_h" in
-- *yes*);;
-- *) for i in /usr/include /usr/local/include; do
-- if test -f "$i/ncurses/curses.h" -a -f "$i/ncurses/unctrl.h"; then
-- AC_MSG_WARN(ncurses test is failure. Please check config.h and common.makefile later)
-- CPPFLAGS="$CPPFLAGS -I$i/ncurses"
-- break
-- fi
-- done
-- ;;
-- esac
--
-- AC_CHECK_LIB(ncurses,initscr,lib_curses_opt=-lncurses,
-- [ dnl checking pdcurses
-- AC_CHECK_LIB(curses,PDC_set_ctrl_break,
-- [ lib_curses_opt=-lcurses
-- AC_DEFINE(USE_PDCURSES,1,Define to 1 if you use PDcurses)
-- lib_user32_opt="$lib_user32_test"
-- ],
-- [ dnl checking libpdcurses
-- AC_CHECK_LIB(pdcurses,PDC_set_ctrl_break,
-- [ lib_curses_opt=-lpdcurses
-- AC_DEFINE(USE_PDCURSES,1,Define to 1 if you use PDcurses)
-- lib_user32_opt="$lib_user32_test"
-- ],
-- [ dnl OpenBSD use -lcurses instead of -lncurses.
-- case "$target" in
-- *openbsd*)
-- AC_CHECK_LIB(curses,initscr,lib_curses_opt=-lcurses,
-- [ AC_MSG_WARN(ncurses interface is not enabled)
-- enable_ncurses=no ])
-- ;;
-- *)
-- if test "x$VCPP" = xyes || test "x$BORLANDC" = xyes || test "x$WATCOM_C" = xyes || test "x$DMC" = xyes || test "x$POCC" = xyes; then
-- lib_curses_opt=libpdcurses.lib
-- AC_DEFINE(USE_PDCURSES,1,Define to 1 if you use PDcurses)
-- else
-- AC_MSG_WARN(ncurses interface is not enabled)
-- enable_ncurses=no
-- fi
-- ;;
-- esac
-- ])
-- ],
-- $lib_user32_test)
-- ])
-+ [ CPPFLAGS="$CPPFLAGS $(${PKG_CONFIG} --cflags ncurses)"
-+ lib_curses_opt=$(${PKG_CONFIG} --libs ncurses)
- ],
- [ LIBS="$LIBS $lib_curses_opt"
- case "$target" in
-@@ -1855,7 +1804,7 @@ CONFIG_INTERFACE(xaw,XAW,a,
- lib_xmu_opt=-lXmu
- lib_xt_opt=-lXt
- if test "x$enable_xft" = "xyes" && test "x$have_xaw" != "xno"; then
-- XFT_CFLAGS="$(pkg-config --cflags xft)";
-+ XFT_CFLAGS="$(${PKG_CONFIG} --cflags xft)";
- EXTRACT_CPPFLAGS(CPPFLAGS,CFLAGS,$XFT_CFLAGS)
- lib_xft_opt="-lXft";
- fi
-@@ -1909,7 +1858,7 @@ CONFIG_INTERFACE(xaw,XAW,a,
- ;;
- esac
- if test "x$enable_xft" = "xyes" && test "x$have_xaw" != "xno"; then
-- XFT_CFLAGS="$(pkg-config --cflags xft)";
-+ XFT_CFLAGS="$(${PKG_CONFIG} --cflags xft)";
- EXTRACT_CPPFLAGS(CPPFLAGS,CFLAGS,$XFT_CFLAGS)
- a_so_libs="$a_so_libs -lXft";
- fi
diff --git a/media-sound/timidity++/files/timidity++-2.14.0-revert-for-required-ctl_speana_data-function.patch b/media-sound/timidity++/files/timidity++-2.14.0-revert-for-required-ctl_speana_data-function.patch
deleted file mode 100644
index 6f901eab8bc0..000000000000
--- a/media-sound/timidity++/files/timidity++-2.14.0-revert-for-required-ctl_speana_data-function.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-This will revert part of the commit from:
-
-http://timidity.git.sourceforge.net/git/gitweb.cgi?p=timidity/timidity;a=commit;h=e73b53437dbc1e57e61dd4d0c1407784797b08d9
-
-Because otherwise TiMidity++ simply won't build as per:
-
-../interface/libinterface.a(xskin_c.o): In function `ctl_event':
-xskin_c.c:(.text+0x17c): undefined reference to `ctl_speana_data'
-collect2: error: ld returned 1 exit status
-
---- a/interface/xskin_c.c
-+++ b/interface/xskin_c.c
-@@ -228,7 +228,6 @@
- }
- }
-
--#if 0
- static void ctl_speana_data(double *val, int size) {
-
- /* 0 <= val[n] <= (AMP*NCOLOR) */
-@@ -280,7 +279,6 @@
-
- return;
- }
--#endif
-
- /*ARGSUSED*/
- static int ctl_open(int using_stdin, int using_stdout) {
diff --git a/media-sound/timidity++/files/timidity++-2.14.0-tcltk86.patch b/media-sound/timidity++/files/timidity++-2.14.0-tcltk86.patch
deleted file mode 100644
index 23ef62aa03e5..000000000000
--- a/media-sound/timidity++/files/timidity++-2.14.0-tcltk86.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-http://bugs.gentoo.org/451296
-
---- a/interface/tk_c.c
-+++ b/interface/tk_c.c
-@@ -913,7 +913,7 @@
- vsnprintf(buf, sizeof(buf), fmt, ap);
- Tcl_Eval(my_interp, buf);
- va_end(ap);
-- return my_interp->result;
-+ return Tcl_GetStringResult(my_interp);
- }
-
- static const char *v_get2(const char *v1, const char *v2)