summaryrefslogtreecommitdiff
path: root/media-sound/xmms2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-12 23:49:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-12 23:49:59 +0100
commit241157fae4eae88cefc48b4644bad8b9e53583dc (patch)
tree21c5bcbe695778c057090452592e3861a780352b /media-sound/xmms2
parent229d5601ae2eca4f143dabdfb36406376cf88c03 (diff)
gentoo auto-resync : 12:05:2023 - 23:49:59
Diffstat (limited to 'media-sound/xmms2')
-rw-r--r--media-sound/xmms2/Manifest2
-rw-r--r--media-sound/xmms2/xmms2-0.9.3.ebuild219
2 files changed, 221 insertions, 0 deletions
diff --git a/media-sound/xmms2/Manifest b/media-sound/xmms2/Manifest
index 16d934f1ef84..73c73ea81880 100644
--- a/media-sound/xmms2/Manifest
+++ b/media-sound/xmms2/Manifest
@@ -1,5 +1,7 @@
AUX xmms2-0.9.1-cpp-client.patch 503 BLAKE2B b8127c72ab8830cb0c4ca45c5c7887f194f5cbe0999167f8eadd803df75ecaaaf3b4246d691be1b6106dbede0b3293747fa6d1cfc5f151968dd26065aa9e3b15 SHA512 3b5703614a3afe49cadaf74b2d5e9d436232af62dc60248f929961806ab058ed8b06df0fd9ec0f958e2b454e3be75028117fc9c7a071bef1f9d2aa5496c448c5
AUX xmms2-0.9.1-faad.patch 437 BLAKE2B 832db481404d470d347ee73ae04064d5ce423aca2a4a7681a80301e33522245429306e26eb200f9e111de60e2fa5341478f51282ee8c2264cf3b60a79b83a797 SHA512 7b5380762e311e1479073ca922343ce5d0dbfe2b3ab0f9218e2d85d52d8a37e301a6bb7bdfc0603b3f72578421df0ff335edb8bd9ea20e485cc1037a2197c62c
DIST xmms2-0.9.2.tar.xz 1740744 BLAKE2B fc3b219c37c909e640a0f55f3280b3a4f1e3965ab6ac2da8814d569e9ff6b95a94b32dee04028e22555465fb02cd52857a6a2aebb4794d71bfa7836db642033e SHA512 07531b8d743e7454d9e2650dbdbaff1d75eb98f01ab9f8d3fa9ba031ef5ac066f69d1ce90c6a860014f1f0f5fd43c6a9a2a0330656d938c300a427e610b540a6
+DIST xmms2-0.9.3.tar.xz 1741548 BLAKE2B 19a99d66d3b6991811c1124b76becaa05d04602a84725ca166141947272a3a033545a2e315a70751e8fab83a9b3b16235f1e408dd13caac0a8e7cbf9e8101e34 SHA512 03f2f6b66a35a8e80fdba3afb2a550c19ce2b7b6d53c63c7a735eb787f79b27a325b0715a31544e87c86e386f54a5a9a89aa3a9e81ae5ed29e362bd7b5bfa1ad
EBUILD xmms2-0.9.2.ebuild 5301 BLAKE2B ffd96216d8b0c98c76c7134219f242b340179ebb289b3bc56eeeee229cd8d8cced7ff8f273896bc6c7f0beca6c9885931533ff1e041b49a5332d7a2fd27fcc81 SHA512 1b65cc10f1b17576b6b6b81f2853037fbdd66a670bf17a6ace07ecc5560cc20b315751c56fdd94ca482f8de944e5c56c9b7d2572e9ecd2e501343d64c79c65a9
+EBUILD xmms2-0.9.3.ebuild 5409 BLAKE2B 3ac7d59711351417666684d70a637b8e44c1233e454383c3c4dde9e585abdded76c1292e8389667da3e5aed1ed4dd16588881c1070196d68178792b54337edc4 SHA512 1639dd296035805127a52190ea2551353a408719aa2fd8da7157deae751bcf3af4ec87f158f3b7b9c67def808b0ed441350fd19e9f3798d398a7aee3a3c08d13
MISC metadata.xml 1472 BLAKE2B 1ad415f39603eb6959f85bad95c95e49c6d36fbed3ea2fbe4e3c58772ed335cc5ec4375f19bfc60493a1c30911109f52e870df45acc36d972b0fc56e44c60803 SHA512 aaa7996662236229f4c78cfac1de6e702991c3191f8c20b25a290b6a0bde29a3a00355ad746a767206ea089e1be88ae79abd3a563ce3a8305480406af62f83e7
diff --git a/media-sound/xmms2/xmms2-0.9.3.ebuild b/media-sound/xmms2/xmms2-0.9.3.ebuild
new file mode 100644
index 000000000000..96309b7bbedc
--- /dev/null
+++ b/media-sound/xmms2/xmms2-0.9.3.ebuild
@@ -0,0 +1,219 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="threads(+)"
+inherit flag-o-matic optfeature perl-functions python-single-r1 waf-utils
+
+DESCRIPTION="X(cross)platform Music Multiplexing System, next generation of the XMMS player"
+HOMEPAGE="https://github.com/XMMS2"
+SRC_URI="https://github.com/xmms2/xmms2-devel/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~loong ~ppc ~riscv ~x86"
+
+# IUSE static map to be passed to --with-{optionals,plugins}=opt1,opt2,...
+# flag:opt = `usev flag opt`, opt = `usev opt`, :opt = `echo opt`
+# (if have a use for some of these disabled features, please fill a bug)
+XMMS2_OPTIONALS=(
+ cxx:xmmsclient++,xmmsclient++-glib :launcher mlib-update:medialib-updater
+ :nycli perl :pixmaps python server:s4 test:tests libvisual:vistest
+ # disabled: et,mdns,migrate-collections,ruby,sqlite2s4,xmmsclient-cf,xmmsclient-ecore
+)
+XMMS2_PLUGINS=(
+ aac:faad airplay alsa ao :asx cdda :cue curl :diskwrite :equalizer
+ ffmpeg:apefile,asf,avcodec,flv,tta :file flac fluidsynth:fluidsynth,mid1,midsquash
+ gme :html ices :icymetaint :id3v2 jack :karaoke :m3u mac +mad mms modplug
+ mp3:mpg123 :mp4 musepack :normalize :null :nulstripper ofa opus oss :pls
+ pulseaudio:pulse :replaygain samba sid sndfile speex tremor vocoder +vorbis
+ :wave wavpack :xml xml:rss,xspf zeroconf:daap
+ # disabled: coreaudio,gvfs,nms,sc68,sun,waveout
+)
+
+IUSE="
+ ${XMMS2_OPTIONALS[@]%:*}
+ ${XMMS2_PLUGINS[@]%:*}
+ +server"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ test? ( server )"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-libs/glib:2
+ sys-libs/readline:=
+ libvisual? (
+ media-libs/libsdl[opengl,video]
+ media-libs/libvisual:0.4
+ )
+ server? (
+ aac? ( media-libs/faad2 )
+ airplay? ( dev-libs/openssl:= )
+ alsa? ( media-libs/alsa-lib )
+ ao? ( media-libs/libao )
+ cdda? (
+ dev-libs/libcdio-paranoia:=
+ dev-libs/libcdio:=
+ media-libs/libdiscid
+ )
+ curl? ( net-misc/curl )
+ ffmpeg? ( media-video/ffmpeg:= )
+ flac? ( media-libs/flac:= )
+ fluidsynth? ( media-sound/fluidsynth:= )
+ gme? ( media-libs/game-music-emu )
+ ices? (
+ media-libs/libogg
+ media-libs/libshout
+ media-libs/libvorbis
+ )
+ jack? ( virtual/jack )
+ mac? ( media-sound/mac )
+ mad? ( media-libs/libmad )
+ mms? (
+ media-libs/libmms
+ media-video/ffmpeg:=
+ )
+ modplug? ( media-libs/libmodplug )
+ mp3? ( media-sound/mpg123 )
+ musepack? ( media-sound/musepack-tools )
+ ofa? (
+ dev-libs/expat
+ media-libs/libofa
+ sci-libs/fftw:3.0=
+ )
+ opus? ( media-libs/opusfile )
+ pulseaudio? ( media-libs/libpulse )
+ samba? ( net-fs/samba )
+ sid? ( media-libs/libsidplay:2 )
+ sndfile? ( media-libs/libsndfile )
+ speex? (
+ media-libs/libogg
+ media-libs/speex
+ )
+ tremor? ( media-libs/tremor )
+ vocoder? (
+ media-libs/libsamplerate
+ sci-libs/fftw:3.0=
+ )
+ vorbis? ( media-libs/libvorbis )
+ wavpack? ( media-sound/wavpack )
+ xml? ( dev-libs/libxml2 )
+ zeroconf? (
+ net-dns/avahi[mdnsresponder-compat]
+ net-misc/curl
+ )
+ )"
+RDEPEND="
+ ${COMMON_DEPEND}
+ perl? (
+ dev-lang/perl
+ dev-perl/glib-perl
+ virtual/perl-Carp
+ virtual/perl-IO
+ virtual/perl-Scalar-List-Utils
+ )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/pygobject[${PYTHON_USEDEP}]')
+ )"
+DEPEND="
+ ${COMMON_DEPEND}
+ cxx? ( dev-libs/boost )
+ test? ( dev-util/cunit )"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ perl? ( dev-perl/Pod-Parser )
+ python? ( $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]') )"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ avcodec_free_frame # succcessfully detects that this is gone in newer ffmpeg
+)
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9.1-cpp-client.patch
+ "${FILESDIR}"/${PN}-0.9.1-faad.patch
+)
+
+src_prepare() {
+ default
+
+ # meant to be configured, but give a default for out-of-the-box midi
+ sed -e "s|/path/to/.*sf2|${EPREFIX}/usr/share/sounds/sf2/FluidR3_GM.sf2|" \
+ -i src/plugins/fluidsynth/fluidsynth.c || die
+}
+
+src_configure() {
+ filter-lto # `xmms2 add somefile` breaks with lto + fortify=2
+
+ local wafargs=(
+ --boost-includes="${ESYSROOT}"/usr/include
+ --with-target-platform="${CHOST}"
+ --without-valgrind
+ )
+
+ xmms2_flag() {
+ local IFS=:
+ set -- ${1#+}
+
+ if [[ ${1} ]]; then
+ usev ${1} ,${2:-${1}}
+ else
+ echo ,${2}
+ fi
+ }
+
+ local flag optionals plugins
+
+ if use server; then
+ for flag in "${XMMS2_PLUGINS[@]}"; do
+ plugins+=$(xmms2_flag ${flag})
+ done
+ else
+ wafargs+=( --without-xmms2d )
+ fi
+
+ for flag in "${XMMS2_OPTIONALS[@]}"; do
+ optionals+=$(xmms2_flag ${flag})
+ done
+
+ wafargs+=(
+ # pass even if empty to avoid automagic
+ --with-optionals=${optionals:1}
+ --with-plugins=${plugins:1}
+ )
+
+ if use perl; then
+ perl_set_version
+ wafargs+=( --with-perl-archdir="${ARCH_LIB}" )
+ fi
+
+ waf-utils_src_configure "${wafargs[@]}"
+}
+
+src_compile() {
+ waf-utils_src_compile --notests
+}
+
+src_test() {
+ waf-utils_src_compile --alltests
+}
+
+src_install() {
+ local DOCS=( AUTHORS README.mdown *.ChangeLog )
+ waf-utils_src_install --without-ldconfig --notests
+
+ use libvisual && dobin _build_/src/clients/vistest/xmms2-libvisual
+
+ use python && python_optimize
+
+ # to avoid editing waftools/man.py (use find given not always installed)
+ find "${ED}" -type f -name '*.gz' -exec gzip -d {} + || die
+}
+
+pkg_postinst() {
+ use fluidsynth && optfeature "the default MIDI soundfont" media-sound/fluid-soundfont
+}