summaryrefslogtreecommitdiff
path: root/media-tv/channeleditor/channeleditor-1.9.2.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-tv/channeleditor/channeleditor-1.9.2.1-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-tv/channeleditor/channeleditor-1.9.2.1-r1.ebuild')
-rw-r--r--media-tv/channeleditor/channeleditor-1.9.2.1-r1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/media-tv/channeleditor/channeleditor-1.9.2.1-r1.ebuild b/media-tv/channeleditor/channeleditor-1.9.2.1-r1.ebuild
new file mode 100644
index 000000000000..b3c5d9fc82b5
--- /dev/null
+++ b/media-tv/channeleditor/channeleditor-1.9.2.1-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE=source
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Editor for VDR channels.conf"
+HOMEPAGE="http://www.renier.de/channeleditor"
+SRC_URI="mirror://sourceforge/${PN}/${P/-/_}_src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=" >=virtual/jdk-1.5"
+
+S="${WORKDIR}/${PN}"
+
+mainclass() {
+ # read Main-Class from MANIFEST.MF
+ sed -n "s/^Main-Class: \([^ ]\+\).*/\1/p" "${S}/MANIFEST.MF" \
+ || die "reading Main-Class failed"
+}
+
+java_prepare() {
+ # move files out of build and remove stuff not needed in the package
+ mv build/* "${S}" || die "cleaning build dir failed"
+ rm -f src/java/org/javalobby/icons/{README,COPYRIGHT} \
+ || die "removing files failed"
+
+ # copy build.xml
+ cp -f "${FILESDIR}/build-${PV}.xml" build.xml \
+ || die "copying build.xml failed"
+
+ # convert CRLF to LF
+ edos2unix MANIFEST.MF
+
+ # include localisation changes
+ epatch "${FILESDIR}"/${P}-messages.properties.patch
+ epatch "${FILESDIR}"/${P}-messages_en.properties.patch
+}
+
+src_compile() {
+ eant build -Dmanifest.mainclass=$(mainclass)
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+ java-pkg_dolauncher ${PN} --main $(mainclass)
+
+ use source && java-pkg_dosrc src
+
+ make_desktop_entry channeleditor Channeleditor "" "Utility"
+}