summaryrefslogtreecommitdiff
path: root/media-tv/channeleditor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-09 00:01:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-09 00:01:03 +0100
commita0ce545d52f231499bf9f3644493113d8af58ec9 (patch)
tree4d67c09eed0c2ae28d1317f72d7f7b08b4f6aeea /media-tv/channeleditor
parent5181ced3f3566a9610b85922b083c8f84f20d78f (diff)
gentoo auto-resync : 09:05:2024 - 00:01:03
Diffstat (limited to 'media-tv/channeleditor')
-rw-r--r--media-tv/channeleditor/Manifest1
-rw-r--r--media-tv/channeleditor/channeleditor-1.9.2.1-r4.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/media-tv/channeleditor/Manifest b/media-tv/channeleditor/Manifest
index b4b4e6dfcf2f..13a21ee8cccb 100644
--- a/media-tv/channeleditor/Manifest
+++ b/media-tv/channeleditor/Manifest
@@ -3,4 +3,5 @@ AUX channeleditor-1.9.2.1-messages.properties.patch 18594 BLAKE2B 0b24118aca4bf3
AUX channeleditor-1.9.2.1-messages_en.properties.patch 7226 BLAKE2B f5992f06de852454a004883d96dc61e56728a745dd03f7545f9854ee839ac55ca511b518aa03e20cbb2a6126bb34964c7af72f4b81536bdcec24f76988826ec0 SHA512 8a2c09010ce01f001150a759bb91fdf2bdebf4a6776ada8fc1dfbb4b9000aeb4d5ad0be5bb99ed4b5237c4a070ebbea5ca862585a74f1c64dad5349127f45a97
DIST channeleditor_1.9.2.1_src.tar.gz 317608 BLAKE2B 26afc8d08a525f26c942fda20eb8ed63ff973bc112743edb80043ef9f2bd78f34dc4b2ef7ad60110b624dbfa6e2058a41e945b616d2ca587acffefe5b15b583e SHA512 84147868aa8b1aacf4ef31a7665822bc7ccd4f7372aaa040aacd8ee42581db1d67092b6b09cda6e447bae2c058fe4ceaab28f3e2a268a54dc5ac25452e64d7d9
EBUILD channeleditor-1.9.2.1-r3.ebuild 1514 BLAKE2B dc62f37f12ed1ac77cdd35d1cee800352c37dd37a086eae7de3149f24f42fec7d0f4e9576816fc10d669384aa8e064eaa355b6cffeb327a1eee144aafc050cc0 SHA512 270330602b122bec025695832a698da141316c2989785cf7b6333afa6c8c475ded313099562022db59177b035800addefafb2ed52714d0ccae022dc56d8f13ff
+EBUILD channeleditor-1.9.2.1-r4.ebuild 1235 BLAKE2B 49401d0712a1c50a0ec042c956731f98fd0a2bfe723e5fdc5623d8282258ebdd30fb9e30dcd4027b1dc50424dec60d3372fa493905e747b86354cac9f2b00226 SHA512 3c51ad4b8d0a54847945fe8b2f607b4e6e0d4ed5cc904e504fb3aa28c8afc6372d70e77bc41ce310e16e02df77016c30c24181cd6ad75f8d4b14bb350c22fdc4
MISC metadata.xml 333 BLAKE2B 628272e16b8267eade20b9f553db0dfc8dd150418e0579fda355621848d0daadc3724c5574d3198c34d45b23db168f31120704be181030956f03c0de33e0543f SHA512 03d81e9ba7910dacad3162c6a11cbe8360e94947c48f8593734f98ba31ae4a029eb79dc5ae001c28d8201f997101212995b000305548fa07f003a7ddb2f3248c
diff --git a/media-tv/channeleditor/channeleditor-1.9.2.1-r4.ebuild b/media-tv/channeleditor/channeleditor-1.9.2.1-r4.ebuild
new file mode 100644
index 000000000000..e09a7fe8c5d0
--- /dev/null
+++ b/media-tv/channeleditor/channeleditor-1.9.2.1-r4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+
+inherit desktop java-pkg-2 java-pkg-simple xdg
+
+DESCRIPTION="Editor for VDR channels.conf"
+HOMEPAGE="https://sites.google.com/site/reniershomepage/channeleditor"
+SRC_URI="https://downloads.sourceforge.net/project/channeleditor/channeleditor/$(ver_cut 1-3)/${P/-/_}_src.tar.gz"
+
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8:*"
+DEPEND=">=virtual/jdk-1.8:*"
+
+PATCHES=(
+ # include localisation changes
+ "${FILESDIR}"/${P}-messages.properties.patch
+ "${FILESDIR}"/${P}-messages_en.properties.patch
+)
+
+JAVA_RESOURCE_DIRS="resources/src/java"
+JAVA_SRC_DIR="src"
+
+src_prepare() {
+ default #780585
+ java-pkg-2_src_prepare
+
+ xdg_environment_reset
+
+ JAVA_MAIN_CLASS="$(grep Main build/MANIFEST.MF | cut -d' ' -f2 | tr -cd [:print:])"
+
+ # java-pkg-simple expects resources in JAVA_RESOURCE_DIRS
+ mkdir -p resources || die
+ find src -type f ! -name '*.java' \
+ ! -name 'README' ! -name 'COPYRIGHT' \
+ | xargs cp --parent -t resources || die
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ make_desktop_entry channeleditor Channeleditor "" "Utility"
+}