summaryrefslogtreecommitdiff
path: root/media-tv/kodi/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-21 08:09:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-21 08:09:25 +0000
commit5adb1b3ff590f0911922679849a7fdacc8b4f217 (patch)
tree8a471fe02dd3498487715d39f928b42017f24c99 /media-tv/kodi/files
parentafcb9236a72cf602364c28b9bde6648e4a7f1ca5 (diff)
gentoo auto-resync : 21:01:2024 - 08:09:25
Diffstat (limited to 'media-tv/kodi/files')
-rw-r--r--media-tv/kodi/files/kodi-20.2-binutils-2.41.patch103
1 files changed, 103 insertions, 0 deletions
diff --git a/media-tv/kodi/files/kodi-20.2-binutils-2.41.patch b/media-tv/kodi/files/kodi-20.2-binutils-2.41.patch
new file mode 100644
index 000000000000..6ee7a55ee1de
--- /dev/null
+++ b/media-tv/kodi/files/kodi-20.2-binutils-2.41.patch
@@ -0,0 +1,103 @@
+https://git.ffmpeg.org/gitweb/ffmpeg.git/commitdiff/effadce6c756247ea8bae32dc13bb3e6f464f0eb
+
+From db99a6e0ed9490478a7af7b6a3299688b1a329e1 Mon Sep 17 00:00:00 2001
+From: Alfred Wingate <parona@protonmail.com>
+Date: Sun, 24 Dec 2023 14:02:37 +0200
+Subject: [PATCH] ffmpeg: add patch to fix build against binutils-2.41
+
+Signed-off-by: Alfred Wingate <parona@protonmail.com>
+--- a/cmake/modules/FindFFMPEG.cmake
++++ b/cmake/modules/FindFFMPEG.cmake
+@@ -96,7 +96,9 @@ macro(buildFFMPEG)
+ -DPKG_CONFIG_PATH=${CMAKE_BINARY_DIR}/${CORE_BUILD_DIR}/lib/pkgconfig)
+ set(PATCH_COMMAND ${CMAKE_COMMAND} -E copy
+ ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/CMakeLists.txt
+- <SOURCE_DIR>)
++ <SOURCE_DIR> &&
++ # patch internal ffmpeg, fix build against binutils 2.41
++ patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/build-fix-for-binutils-2.41.patch)
+
+ if(CMAKE_GENERATOR STREQUAL Xcode)
+ set(FFMPEG_GENERATOR CMAKE_GENERATOR "Unix Makefiles")
+--- /dev/null
++++ b/tools/depends/target/ffmpeg/build-fix-for-binutils-2.41.patch
+@@ -0,0 +1,76 @@
++From effadce6c756247ea8bae32dc13bb3e6f464f0eb Mon Sep 17 00:00:00 2001
++From: =?utf8?q?R=C3=A9mi=20Denis-Courmont?= <remi@remlab.net>
++Date: Sun, 16 Jul 2023 18:18:02 +0300
++Subject: [PATCH] avcodec/x86/mathops: clip constants used with shift
++ instructions within inline assembly
++
++Fixes assembling with binutil as >= 2.41
++
++Signed-off-by: James Almer <jamrial@gmail.com>
++---
++ libavcodec/x86/mathops.h | 26 +++++++++++++++++++++++---
++ 1 file changed, 23 insertions(+), 3 deletions(-)
++
++diff --git a/libavcodec/x86/mathops.h b/libavcodec/x86/mathops.h
++index 6298f5ed19..ca7e2dffc1 100644
++--- a/libavcodec/x86/mathops.h
+++++ b/libavcodec/x86/mathops.h
++@@ -35,12 +35,20 @@
++ static av_always_inline av_const int MULL(int a, int b, unsigned shift)
++ {
++ int rt, dummy;
+++ if (__builtin_constant_p(shift))
++ __asm__ (
++ "imull %3 \n\t"
++ "shrdl %4, %%edx, %%eax \n\t"
++ :"=a"(rt), "=d"(dummy)
++- :"a"(a), "rm"(b), "ci"((uint8_t)shift)
+++ :"a"(a), "rm"(b), "i"(shift & 0x1F)
++ );
+++ else
+++ __asm__ (
+++ "imull %3 \n\t"
+++ "shrdl %4, %%edx, %%eax \n\t"
+++ :"=a"(rt), "=d"(dummy)
+++ :"a"(a), "rm"(b), "c"((uint8_t)shift)
+++ );
++ return rt;
++ }
++
++@@ -113,19 +121,31 @@ __asm__ volatile(\
++ // avoid +32 for shift optimization (gcc should do that ...)
++ #define NEG_SSR32 NEG_SSR32
++ static inline int32_t NEG_SSR32( int32_t a, int8_t s){
+++ if (__builtin_constant_p(s))
++ __asm__ ("sarl %1, %0\n\t"
++ : "+r" (a)
++- : "ic" ((uint8_t)(-s))
+++ : "i" (-s & 0x1F)
++ );
+++ else
+++ __asm__ ("sarl %1, %0\n\t"
+++ : "+r" (a)
+++ : "c" ((uint8_t)(-s))
+++ );
++ return a;
++ }
++
++ #define NEG_USR32 NEG_USR32
++ static inline uint32_t NEG_USR32(uint32_t a, int8_t s){
+++ if (__builtin_constant_p(s))
++ __asm__ ("shrl %1, %0\n\t"
++ : "+r" (a)
++- : "ic" ((uint8_t)(-s))
+++ : "i" (-s & 0x1F)
++ );
+++ else
+++ __asm__ ("shrl %1, %0\n\t"
+++ : "+r" (a)
+++ : "c" ((uint8_t)(-s))
+++ );
++ return a;
++ }
++
++--
++2.25.1
++
+--
+2.43.0
+