summaryrefslogtreecommitdiff
path: root/media-video/alevt/alevt-1.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-video/alevt/alevt-1.6.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-video/alevt/alevt-1.6.2.ebuild')
-rw-r--r--media-video/alevt/alevt-1.6.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-video/alevt/alevt-1.6.2.ebuild b/media-video/alevt/alevt-1.6.2.ebuild
new file mode 100644
index 000000000000..5e65dbcd0b4b
--- /dev/null
+++ b/media-video/alevt/alevt-1.6.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="Teletext viewer for X11"
+HOMEPAGE="http://www.goron.de/~froese/"
+SRC_URI="http://www.goron.de/~froese/alevt/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ >=media-libs/libpng-1.4"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+RESTRICT="strip"
+
+src_prepare() {
+ cp -va Makefile{,.orig}
+
+ epatch \
+ "${FILESDIR}"/${P}-respectflags.patch \
+ "${FILESDIR}"/${P}-libpng15.patch
+}
+
+src_compile() {
+ append-flags -fno-strict-aliasing
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin alevt alevt-cap alevt-date
+ doman alevt.1x alevt-date.1 alevt-cap.1
+ dodoc CHANGELOG README
+
+ insinto /usr/share/icons/hicolor/16x16/apps
+ newins contrib/mini-alevt.xpm alevt.xpm
+ insinto /usr/share/icons/hicolor/48x48/apps
+ newins contrib/icon48x48.xpm alevt.xpm
+
+ make_desktop_entry alevt "AleVT" alevt
+}