summaryrefslogtreecommitdiff
path: root/media-video/ccextractor/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /media-video/ccextractor/files
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'media-video/ccextractor/files')
-rw-r--r--media-video/ccextractor/files/ccextractor-0.85-fno-common.patch13
-rw-r--r--media-video/ccextractor/files/ccextractor-0.88-cflags.patch13
-rw-r--r--media-video/ccextractor/files/ccextractor-0.88-fno-common.patch55
-rw-r--r--media-video/ccextractor/files/ccextractor-0.88-libdir.patch12
4 files changed, 93 insertions, 0 deletions
diff --git a/media-video/ccextractor/files/ccextractor-0.85-fno-common.patch b/media-video/ccextractor/files/ccextractor-0.85-fno-common.patch
new file mode 100644
index 000000000000..6e543f74910a
--- /dev/null
+++ b/media-video/ccextractor/files/ccextractor-0.85-fno-common.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/706934
+--- a/lib_ccx/ccx_decoders_708.h
++++ b/lib_ccx/ccx_decoders_708.h
+@@ -368,7 +368,7 @@
+ unsigned char *data,
+ int data_length);
+
+-ccx_dtvcc_pen_color ccx_dtvcc_default_pen_color;
+-ccx_dtvcc_pen_attribs ccx_dtvcc_default_pen_attribs;
++extern ccx_dtvcc_pen_color ccx_dtvcc_default_pen_color;
++extern ccx_dtvcc_pen_attribs ccx_dtvcc_default_pen_attribs;
+
+ #endif
diff --git a/media-video/ccextractor/files/ccextractor-0.88-cflags.patch b/media-video/ccextractor/files/ccextractor-0.88-cflags.patch
new file mode 100644
index 000000000000..7f0e0e9b23dd
--- /dev/null
+++ b/media-video/ccextractor/files/ccextractor-0.88-cflags.patch
@@ -0,0 +1,13 @@
+diff --git a/lib_ccx/CMakeLists.txt b/lib_ccx/CMakeLists.txt
+index 172ef42..0d00660 100644
+--- a/lib_ccx/CMakeLists.txt
++++ b/lib_ccx/CMakeLists.txt
+@@ -3,7 +3,7 @@ cmake_policy (SET CMP0037 NEW)
+ if(MSVC)
+ set (CMAKE_C_FLAGS "-W3 /wd4005 /wd4996")
+ else (MSVC)
+- set (CMAKE_C_FLAGS "-Wall -g -std=gnu99")
++ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99")
+ endif(MSVC)
+
+ if(WIN32)
diff --git a/media-video/ccextractor/files/ccextractor-0.88-fno-common.patch b/media-video/ccextractor/files/ccextractor-0.88-fno-common.patch
new file mode 100644
index 000000000000..1f42132bf8bd
--- /dev/null
+++ b/media-video/ccextractor/files/ccextractor-0.88-fno-common.patch
@@ -0,0 +1,55 @@
+From dfd25022e2a775a8b5eb03e4ad28bab6fe6a0658 Mon Sep 17 00:00:00 2001
+From: Ed Marshall <esm@logic.net>
+Date: Sat, 1 Feb 2020 15:03:22 -0800
+Subject: [PATCH] Fix multiple definitions with new -fno-common default in GCC
+ 10
+
+---
+ ccextractor.c | 3 +++
+ ccextractor.h | 4 ++--
+ lib_ccx/ccx_decoders_708.h | 4 ++--
+ 3 files changed, 7 insertions(+), 4 deletions(-)
+
+diff --git a/ccextractor.c b/ccextractor.c
+index a2fb0a24f..8ed27936d 100644
+--- a/ccextractor.c
++++ b/ccextractor.c
+@@ -9,6 +9,9 @@ License: GPL 2.0
+
+ volatile int terminate_asap = 0;
+
++struct ccx_s_options ccx_options;
++struct lib_ccx_ctx *signal_ctx;
++
+ void sigusr1_handler(int sig)
+ {
+ mprint("Caught SIGUSR1. Filename Change Requested\n");
+diff --git a/ccextractor.h b/ccextractor.h
+index 4e9ae68f6..e5cde3055 100644
+--- a/ccextractor.h
++++ b/ccextractor.h
+@@ -41,8 +41,8 @@ char * api_param(struct ccx_s_options* api_options, int count);
+ #endif
+
+
+-struct ccx_s_options ccx_options;
+-struct lib_ccx_ctx *signal_ctx;
++extern struct ccx_s_options ccx_options;
++extern struct lib_ccx_ctx *signal_ctx;
+ //volatile int terminate_asap = 0;
+
+ struct ccx_s_options* api_init_options();
+diff --git a/lib_ccx/ccx_decoders_708.h b/lib_ccx/ccx_decoders_708.h
+index 324f3890d..df52c6002 100644
+--- a/lib_ccx/ccx_decoders_708.h
++++ b/lib_ccx/ccx_decoders_708.h
+@@ -371,7 +371,7 @@ void ccx_dtvcc_process_service_block(ccx_dtvcc_ctx *dtvcc,
+ unsigned char *data,
+ int data_length);
+
+-ccx_dtvcc_pen_color ccx_dtvcc_default_pen_color;
+-ccx_dtvcc_pen_attribs ccx_dtvcc_default_pen_attribs;
++extern ccx_dtvcc_pen_color ccx_dtvcc_default_pen_color;
++extern ccx_dtvcc_pen_attribs ccx_dtvcc_default_pen_attribs;
+
+ #endif
diff --git a/media-video/ccextractor/files/ccextractor-0.88-libdir.patch b/media-video/ccextractor/files/ccextractor-0.88-libdir.patch
new file mode 100644
index 000000000000..bb22a4b8a35a
--- /dev/null
+++ b/media-video/ccextractor/files/ccextractor-0.88-libdir.patch
@@ -0,0 +1,12 @@
+diff --git a/lib_ccx/CMakeLists.txt b/lib_ccx/CMakeLists.txt
+index 5a784a9..172ef42 100644
+--- a/lib_ccx/CMakeLists.txt
++++ b/lib_ccx/CMakeLists.txt
+@@ -107,6 +107,6 @@ file (WRITE ccx.pc "prefix=${CMAKE_INSTALL_PREFIX}\n"
+ "Libs.private: -lpng\n"
+ )
+
+-install (TARGETS ccx DESTINATION lib)
++install (TARGETS ccx DESTINATION ${CMAKE_INSTALL_LIBDIR})
+ install (FILES ${HeaderFiles} DESTINATION include)
+ install (FILES ccx.pc DESTINATION lib/pkgconfig)