summaryrefslogtreecommitdiff
path: root/media-video/dvd_info/dvd_info-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-02 08:48:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-02 08:48:32 +0000
commite12724a13a1677867978f5ecd7fabda4eb1e3aa8 (patch)
treec4a7ae297f78e8e1302dc99fe9b664b7f34ce937 /media-video/dvd_info/dvd_info-9999.ebuild
parentb46ba5cce8bd84d9a74b39923d9cdb29659cf662 (diff)
gentoo auto-resync : 02:01:2024 - 08:48:32
Diffstat (limited to 'media-video/dvd_info/dvd_info-9999.ebuild')
-rw-r--r--media-video/dvd_info/dvd_info-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-video/dvd_info/dvd_info-9999.ebuild b/media-video/dvd_info/dvd_info-9999.ebuild
new file mode 100644
index 000000000000..90d0eecc2622
--- /dev/null
+++ b/media-video/dvd_info/dvd_info-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/beandog/dvd_info.git"
+else
+ SRC_URI="https://github.com/beandog/dvd_info/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="DVD utilities to print information, copy tracks, backup, etc"
+HOMEPAGE="https://github.com/beandog/dvd_info"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+libmpv"
+
+DEPEND="
+ media-libs/libdvdread
+ libmpv? ( media-video/mpv[libmpv,dvd] )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_with libmpv)
+}