summaryrefslogtreecommitdiff
path: root/media-video/ffmpeg/ffmpeg-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
commit265dbe5dbc14c199299496c6db8fce3f76647015 (patch)
treeab18b5617d138f6684566b619405090989d55a2c /media-video/ffmpeg/ffmpeg-9999.ebuild
parent586819755b4dbfdffdc8a725ab7c0f86095b8489 (diff)
gentoo resync : 21.09.2018
Diffstat (limited to 'media-video/ffmpeg/ffmpeg-9999.ebuild')
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 464a797c81b0..a6f55da8a28e 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -24,13 +24,13 @@ fi
inherit eutils flag-o-matic multilib multilib-minimal toolchain-funcs ${SCM}
DESCRIPTION="Complete solution to record, convert and stream audio and video. Includes libavcodec"
-HOMEPAGE="http://ffmpeg.org/"
+HOMEPAGE="https://ffmpeg.org/"
if [ "${PV#9999}" != "${PV}" ] ; then
SRC_URI=""
elif [ "${PV%_p*}" != "${PV}" ] ; then # Snapshot
SRC_URI="mirror://gentoo/${P}.tar.bz2"
else # Release
- SRC_URI="http://ffmpeg.org/releases/${P/_/-}.tar.bz2"
+ SRC_URI="https://ffmpeg.org/releases/${P/_/-}.tar.bz2"
fi
FFMPEG_REVISION="${PV#*_p}"
@@ -74,7 +74,7 @@ FFMPEG_FLAG_MAP=(
libv4l:libv4l2 pulseaudio:libpulse libdrm
# decoders
amr:libopencore-amrwb amr:libopencore-amrnb codec2:libcodec2 fdk:libfdk-aac
- jpeg2k:libopenjpeg bluray:libbluray celt:libcelt gme:libgme gsm:libgsm
+ jpeg2k:libopenjpeg bluray:libbluray gme:libgme gsm:libgsm
mmal modplug:libmodplug opus:libopus libilbc librtmp ssh:libssh
speex:libspeex svg:librsvg video_cards_nvidia:ffnvcodec
vorbis:libvorbis vpx:libvpx zvbi:libzvbi
@@ -168,7 +168,6 @@ RDEPEND="
bs2b? ( >=media-libs/libbs2b-3.1.0-r1[${MULTILIB_USEDEP}] )
bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
cdio? ( >=dev-libs/libcdio-paranoia-0.90_p1-r1[${MULTILIB_USEDEP}] )
- celt? ( >=media-libs/celt-0.11.1-r1[${MULTILIB_USEDEP}] )
chromaprint? ( >=media-libs/chromaprint-1.2-r1[${MULTILIB_USEDEP}] )
codec2? ( media-libs/codec2[${MULTILIB_USEDEP}] )
encode? (
@@ -404,6 +403,7 @@ multilib_src_configure() {
--enable-avfilter
--enable-avresample
--disable-stripping
+ --disable-libcelt # bug #664158
"${myconf[@]}"
)