summaryrefslogtreecommitdiff
path: root/media-video/gpac/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /media-video/gpac/files
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'media-video/gpac/files')
-rw-r--r--media-video/gpac/files/ffmpeg4.patch44
-rw-r--r--media-video/gpac/files/gpac-0.7.1-configure.patch94
-rw-r--r--media-video/gpac/files/gpac-0.7.1-openssl-1.1.patch126
-rw-r--r--media-video/gpac/files/gpac-freetype.patch15
4 files changed, 0 insertions, 279 deletions
diff --git a/media-video/gpac/files/ffmpeg4.patch b/media-video/gpac/files/ffmpeg4.patch
deleted file mode 100644
index 61f329806a55..000000000000
--- a/media-video/gpac/files/ffmpeg4.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-Index: gpac-0.7.1/applications/dashcast/video_encoder.c
-===================================================================
---- gpac-0.7.1.orig/applications/dashcast/video_encoder.c
-+++ gpac-0.7.1/applications/dashcast/video_encoder.c
-@@ -144,7 +144,7 @@ int dc_video_encoder_open(VideoOutputFil
- }
-
- //the global header gives access to the extradata (SPS/PPS)
-- video_output_file->codec_ctx->flags |= CODEC_FLAG_GLOBAL_HEADER;
-+ video_output_file->codec_ctx->flags |= AV_CODEC_FLAG_GLOBAL_HEADER;
-
- video_output_file->vstream_idx = 0;//video_stream->index;
-
-Index: gpac-0.7.1/modules/ffmpeg_in/ffmpeg_decode.c
-===================================================================
---- gpac-0.7.1.orig/modules/ffmpeg_in/ffmpeg_decode.c
-+++ gpac-0.7.1/modules/ffmpeg_in/ffmpeg_decode.c
-@@ -49,7 +49,7 @@
- static uint8_t * ffmpeg_realloc_buffer(uint8_t * oldBuffer, u32 size) {
- uint8_t * buffer;
- /* Size of buffer must be larger, see avcodec_decode_video2 documentation */
-- u32 allocatedSz = sizeof( char ) * (FF_INPUT_BUFFER_PADDING_SIZE + size);
-+ u32 allocatedSz = sizeof( char ) * (AV_INPUT_BUFFER_PADDING_SIZE + size);
- if (oldBuffer)
- gf_free(oldBuffer);
- buffer = (uint8_t*)gf_malloc( allocatedSz );
-@@ -577,7 +577,7 @@ static GF_Err FFDEC_GetCapabilities(GF_B
- capability->cap.valueInt = 1;
- return GF_OK;
- case GF_CODEC_PADDING_BYTES:
-- capability->cap.valueInt = FF_INPUT_BUFFER_PADDING_SIZE;
-+ capability->cap.valueInt = AV_INPUT_BUFFER_PADDING_SIZE;
- return GF_OK;
- case GF_CODEC_REORDER:
- capability->cap.valueInt = 1;
-@@ -669,7 +669,7 @@ static GF_Err FFDEC_GetCapabilities(GF_B
- break;
-
- case GF_CODEC_PADDING_BYTES:
-- capability->cap.valueInt = FF_INPUT_BUFFER_PADDING_SIZE;
-+ capability->cap.valueInt = AV_INPUT_BUFFER_PADDING_SIZE;
- break;
- default:
- capability->cap.valueInt = 0;
diff --git a/media-video/gpac/files/gpac-0.7.1-configure.patch b/media-video/gpac/files/gpac-0.7.1-configure.patch
deleted file mode 100644
index 8bc3ec9f9079..000000000000
--- a/media-video/gpac/files/gpac-0.7.1-configure.patch
+++ /dev/null
@@ -1,94 +0,0 @@
---- gpac-0.7.1/Makefile.orig 2017-07-25 09:34:51.910379115 -0600
-+++ gpac-0.7.1/Makefile 2017-07-25 09:36:18.906385736 -0600
-@@ -252,7 +252,9 @@
- $(INSTALL) $(INSTFLAGS) -m 644 $(SRC_PATH)/include/gpac/enst/*.h "$(DESTDIR)$(prefix)/include/gpac/enst"
- endif
- mkdir -p "$(DESTDIR)$(prefix)/$(libdir)"
-+ifeq ($(STATIC_LIBS),yes)
- $(INSTALL) $(INSTFLAGS) -m 644 "./bin/gcc/libgpac_static.a" "$(DESTDIR)$(prefix)/$(libdir)"
-+endif
- $(MAKE) installdylib
-
- uninstall-lib:
---- gpac-0.7.1/src/Makefile.orig 2017-07-25 09:37:48.157392528 -0600
-+++ gpac-0.7.1/src/Makefile 2017-07-25 09:39:06.092398459 -0600
-@@ -267,16 +267,20 @@
-
- ifeq ($(CONFIG_DARWIN),yes)
-
-+ifeq ($(STATICLIBS),yes)
- $(LIBTOOL) -s -o ../bin/gcc/libgpac_static.a $(OBJS)
- $(RANLIB) ../bin/gcc/libgpac_static.a
-+endif
- ifneq ($(STATICBUILD),yes)
- $(CC) $(SHFLAGS) $(LD_SONAME) -o $@ $(OBJS) $(EXTRALIBS) $(LDFLAGS)
- endif
-
- else
-
-+ifeq ($(STATICLIBS),yes)
- $(AR) cr ../bin/gcc/libgpac_static.a $(OBJS)
- $(RANLIB) ../bin/gcc/libgpac_static.a
-+endif
- ifneq ($(STATICBUILD),yes)
- $(CC) $(SHFLAGS) $(LD_SONAME) -o $@ $(OBJS) $(EXTRALIBS) $(LDFLAGS)
- mv $@ $@.$(VERSION_SONAME)
---- gpac-0.7.1/configure.orig 2017-07-25 10:01:58.789502926 -0600
-+++ gpac-0.7.1/configure 2017-07-25 10:02:54.110507136 -0600
-@@ -109,6 +109,7 @@
- has_openjpeg="no"
- gprof_build="no"
- static_build="no"
-+static_libs="no"
- want_pic="no"
- want_gcov="no"
- has_joystick="no"
-@@ -260,6 +261,7 @@
- --enable-amr-wb enable AMR WB library
- --enable-amr enable both AMR NB and WB libraries
- --enable-static-bin link statically against libgpac
-+ --enable-static-lib GPAC static libraries build
- --static-mp4box configure for static linking of MP4Box only.
- --enable-depth enables depth handling in the compositor
-
-@@ -705,15 +707,6 @@
- CFLAGS="$CFLAGS -Wno-pointer-sign"
- fi
-
--
--#GCC opt
--if test "$no_gcc_opt" = "no"; then
-- CFLAGS="-O3 $CFLAGS"
--else
-- CFLAGS="-O0 $CFLAGS"
--fi
--
--
- #GCC PIC
- if test "$cross_prefix" != "" ; then
- want_pic="no"
-@@ -1885,6 +1878,8 @@
- ;;
- --enable-static-bin) static_build="yes";
- ;;
-+ --enable-static-lib) static_libs="yes";
-+ ;;
- --disable-ipv6) has_ipv6="no"
- ;;
- --disable-wx) has_wx="no"
-@@ -2559,6 +2554,7 @@
- echo "debug version: $debuginfo"
- echo "GProf enabled: $gprof_build"
- echo "Static build enabled: $static_build"
-+echo "Static libs enabled: $static_libs"
- echo "Memory tracking enabled: $use_memory_tracking"
- echo "Fixed-Point Version: $use_fixed_point"
- echo "IPV6 Support: $has_ipv6"
-@@ -3194,6 +3190,7 @@
- echo "GPROFBUILD=$gprof_build" >> config.mak
- echo "MP4BOX_STATIC=$static_mp4box" >> config.mak
- echo "STATICBUILD=$static_build" >> config.mak
-+echo "STATICLIBS=$static_libs" >> config.mak
-
- echo "CONFIG_IPV6=$has_ipv6" >> config.mak
- if test "$has_ipv6" = "yes" ; then
diff --git a/media-video/gpac/files/gpac-0.7.1-openssl-1.1.patch b/media-video/gpac/files/gpac-0.7.1-openssl-1.1.patch
deleted file mode 100644
index e25a5bca78bb..000000000000
--- a/media-video/gpac/files/gpac-0.7.1-openssl-1.1.patch
+++ /dev/null
@@ -1,126 +0,0 @@
-From e64a7d229fdcb5c190064b7860ade50124dcc735 Mon Sep 17 00:00:00 2001
-From: Aurelien David <aurelien.david@telecom-paristech.fr>
-Date: Fri, 6 Oct 2017 16:46:18 +0200
-Subject: [PATCH] compatibility with OpenSSL 1.1.x (#616)
-
-diff --git a/src/utils/downloader.c b/src/utils/downloader.c
-index b8c923b88..3b7d37b41 100644
---- a/src/utils/downloader.c
-+++ b/src/utils/downloader.c
-@@ -204,7 +204,7 @@ struct __gf_download_manager
- u32 limit_data_rate, read_buf_size;
- u64 max_cache_size;
- Bool allow_broken_certificate;
--
-+
- GF_List *skip_proxy_servers;
- GF_List *credentials;
- GF_List *cache_entries;
-@@ -392,10 +392,18 @@ static Bool init_ssl_lib() {
- GF_LOG(GF_LOG_ERROR, GF_LOG_NETWORK, ("[HTTPS] Error while initializing Random Number generator, failed to init SSL !\n"));
- return GF_TRUE;
- }
-+
-+ /* per https://www.openssl.org/docs/man1.1.0/ssl/OPENSSL_init_ssl.html
-+ ** As of version 1.1.0 OpenSSL will automatically allocate all resources that it needs so no explicit initialisation is required.
-+ ** Similarly it will also automatically deinitialise as required.
-+ */
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
- SSL_library_init();
- SSL_load_error_strings();
- SSLeay_add_all_algorithms();
- SSLeay_add_ssl_algorithms();
-+#endif
-+
- _ssl_is_initialized = GF_TRUE;
- GF_LOG(GF_LOG_DEBUG, GF_LOG_NETWORK, ("[HTTPS] Initalization of SSL library complete.\n"));
- return GF_FALSE;
-@@ -422,6 +430,7 @@ static int ssl_init(GF_DownloadManager *dm, u32 mode)
- }
-
- switch (mode) {
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
- case 0:
- meth = SSLv23_client_method();
- break;
-@@ -436,6 +445,11 @@ static int ssl_init(GF_DownloadManager *dm, u32 mode)
- case 3:
- meth = TLSv1_client_method();
- break;
-+#else /* for openssl 1.1+ this is the prefered method */
-+ case 0:
-+ meth = TLS_client_method();
-+ break;
-+#endif
- default:
- goto error;
- }
-@@ -771,7 +785,7 @@ void gf_dm_sess_del(GF_DownloadSession *sess)
- gf_sk_del(sess->sock);
- gf_list_del(sess->headers);
- gf_mx_del(sess->mx);
--
-+
- gf_free(sess);
- GF_LOG(GF_LOG_DEBUG, GF_LOG_NETWORK, ("[Downloader] gf_dm_sess_del(%p) : DONE\n", sess ));
- }
-@@ -1145,7 +1159,7 @@ GF_DownloadSession *gf_dm_sess_new_simple(GF_DownloadManager * dm, const char *u
- {
- GF_DownloadSession *sess;
- if (!dm) return NULL;
--
-+
- GF_SAFEALLOC(sess, GF_DownloadSession);
- if (!sess) {
- GF_LOG(GF_LOG_ERROR, GF_LOG_NETWORK, ("%s:%d Cannot allocate session for URL %s: OUT OF MEMORY!\n", __FILE__, __LINE__, url));
-@@ -1166,8 +1180,8 @@ GF_DownloadSession *gf_dm_sess_new_simple(GF_DownloadManager * dm, const char *u
- gf_free(sess);
- return NULL;
- }
--
--
-+
-+
- assert( dm );
-
- *e = gf_dm_sess_setup_from_url(sess, url);
-@@ -1225,7 +1239,7 @@ static GF_Err gf_dm_read_data(GF_DownloadSession *sess, char *data, u32 data_siz
- gf_mx_v(sess->mx);
- return GF_IP_CONNECTION_CLOSED;
- }
--
-+
- #ifdef GPAC_HAS_SSL
- if (sess->ssl) {
- s32 size;
-@@ -1451,7 +1465,11 @@ static void gf_dm_connect(GF_DownloadSession *sess)
- const GENERAL_NAME *altname = sk_GENERAL_NAME_value(altnames, i);
- if (altname->type == GEN_DNS)
- {
-- unsigned char *altname_str = ASN1_STRING_data(altname->d.ia5);
-+ #if OPENSSL_VERSION_NUMBER < 0x10100000L
-+ unsigned char *altname_str = ASN1_STRING_data(altname->d.ia5);
-+ #else
-+ unsigned char *altname_str = (unsigned char *)ASN1_STRING_get0_data(altname->d.ia5);
-+ #endif
- gf_list_add(valid_names, altname_str);
- }
- }
-@@ -1806,7 +1824,7 @@ GF_DownloadManager *gf_dm_new(GF_Config *cfg)
- dm->limit_data_rate = 1000 * atoi(opt) / 8;
- else
- gf_cfg_set_key(cfg, "Downloader", "MaxRate", "0");
--
-+
-
- dm->read_buf_size = GF_DOWNLOAD_BUFFER_SIZE;
- //when rate is limited, use smaller smaller read size
-@@ -2943,7 +2961,7 @@ static GF_Err wait_for_header_and_parse(GF_DownloadSession *sess, char * sHTTP)
- hdrp->value = gf_strdup(hdr_val);
- gf_list_add(sess->headers, hdrp);
- }
--
-+
- if (sep) sep[0]=':';
- if (hdr_sep) hdr_sep[0] = '\r';
- }
diff --git a/media-video/gpac/files/gpac-freetype.patch b/media-video/gpac/files/gpac-freetype.patch
deleted file mode 100644
index 98224aff30e1..000000000000
--- a/media-video/gpac/files/gpac-freetype.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Index: gpac-0.7.1/configure
-===================================================================
---- gpac-0.7.1.orig/configure
-+++ gpac-0.7.1/configure
-@@ -1117,8 +1117,8 @@ if docc $CFLAGS_DIR $ft_cflags $ft_lflag
- fi
- if test "$cross_prefix" = "" ; then
- if test "$has_ft" = "no" ; then
-- ft_cflags="`freetype-config --cflags 2>>$logs`"
-- ft_lflags="`freetype-config --libs 2>>$logs`"
-+ ft_cflags="`pkg-config --cflags freetype2 2>>$logs`"
-+ ft_lflags="`pkg-config --libs freetype2 2>>$logs`"
- if docc $ft_cflags $ft_lflags $LDFLAGS ; then
- has_ft="system"
- fi