summaryrefslogtreecommitdiff
path: root/media-video/h264enc/h264enc-10.4.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /media-video/h264enc/h264enc-10.4.7-r1.ebuild
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'media-video/h264enc/h264enc-10.4.7-r1.ebuild')
-rw-r--r--media-video/h264enc/h264enc-10.4.7-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-video/h264enc/h264enc-10.4.7-r1.ebuild b/media-video/h264enc/h264enc-10.4.7-r1.ebuild
new file mode 100644
index 000000000000..51adbd9620cd
--- /dev/null
+++ b/media-video/h264enc/h264enc-10.4.7-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="Script to encode H.264/AVC/MPEG-4 Part 10 formats"
+HOMEPAGE="https://h264enc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="media-video/mplayer[encode,x264]
+ sys-apps/coreutils
+ sys-apps/pv
+ sys-devel/bc
+ sys-process/time"
+
+PATCHES=( "${FILESDIR}/${P}-libaacplusenc.patch" )
+
+src_install() {
+ dobin ${PN}
+ doman man/${PN}.1
+ dodoc doc/*
+ docinto matrices
+ dodoc matrices/*
+}
+
+pkg_postinst() {
+ elog "Optional encoders:"
+ optfeature "aac support" "media-libs/faac media-libs/libaacplus"
+ optfeature "dvd support" media-video/lsdvd
+ optfeature "flac support" media-libs/flac
+ optfeature "lame (mp3) support" media-sound/lame
+ optfeature "matroska (mkv) support" media-video/mkvtoolnix
+ optfeature "mp4 support" media-video/gpac[a52]
+ optfeature "ogm support" media-sound/ogmtools
+ optfeature "vorbis support" media-sound/vorbis-tools
+}