summaryrefslogtreecommitdiff
path: root/media-video/handbrake/handbrake-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /media-video/handbrake/handbrake-9999.ebuild
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'media-video/handbrake/handbrake-9999.ebuild')
-rw-r--r--media-video/handbrake/handbrake-9999.ebuild45
1 files changed, 28 insertions, 17 deletions
diff --git a/media-video/handbrake/handbrake-9999.ebuild b/media-video/handbrake/handbrake-9999.ebuild
index 26469e6268b5..f75730cee0d1 100644
--- a/media-video/handbrake/handbrake-9999.ebuild
+++ b/media-video/handbrake/handbrake-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_{1,2,3,4,5,6,7} python2_7 )
inherit autotools eutils gnome2-utils python-any-r1 xdg-utils
@@ -23,27 +23,30 @@ HOMEPAGE="http://handbrake.fr/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="+fdk gstreamer gtk libav libav-aac x265"
+IUSE="+fdk gstreamer gtk libav libav-aac nvenc x265"
REQUIRED_USE="^^ ( fdk libav-aac )"
RDEPEND="
+ app-arch/xz-utils
+ media-libs/speex
dev-libs/jansson
media-libs/a52dec
media-libs/libass:=
>=media-libs/libbluray-1.0
media-libs/libdvdnav
- media-libs/libdvdread
+ media-libs/libdvdread:=
media-libs/libsamplerate
media-libs/libtheora
media-libs/libvorbis
- media-libs/libvpx
+ >=media-libs/libvpx-1.8
+ nvenc? ( media-libs/nv-codec-headers )
media-libs/opus
media-libs/x264:=
media-sound/lame
sys-libs/zlib
- libav? ( >=media-video/libav-12.3:0=[fdk?] )
- !libav? ( >=media-video/ffmpeg-3.4:0=[fdk?] )
+ libav? ( >=media-video/libav-12.2:0=[fdk?] )
+ !libav? ( >=media-video/ffmpeg-4.2.1:0=[fdk?] )
gstreamer? (
media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0
@@ -53,6 +56,7 @@ RDEPEND="
media-plugins/gst-plugins-a52dec:1.0
media-plugins/gst-plugins-libav:1.0
media-plugins/gst-plugins-x264:1.0
+ media-plugins/gst-plugins-gdkpixbuf:1.0
)
gtk? (
>=x11-libs/gtk+-3.10
@@ -65,7 +69,7 @@ RDEPEND="
x11-libs/pango
)
fdk? ( media-libs/fdk-aac )
- x265? ( >=media-libs/x265-1.7:0= )
+ x265? ( >=media-libs/x265-2.9:0= )
"
DEPEND="${RDEPEND}
@@ -82,8 +86,8 @@ PATCHES=(
# Remove faac dependency; TODO: figure out if we need to do this at all.
"${FILESDIR}/${PN}-9999-remove-faac-dependency.patch"
- # Fix missing x265 link flag
- "${FILESDIR}/${PN}-9999-fix-missing-x265-link-flag.patch"
+ # Fix missing -ldl
+ "${FILESDIR}/${PN}-9999-libdl-link.patch"
)
pkg_setup() {
@@ -98,9 +102,6 @@ src_prepare() {
default
- # Get rid of libav specific code when using ffmpeg
- use libav || eapply -R "${FILESDIR}/${PN}-1.1.0-nolibav.patch"
-
cd "${S}/gtk"
# Don't run autogen.sh.
sed -i '/autogen.sh/d' module.rules || die "Removing autogen.sh call failed"
@@ -108,15 +109,21 @@ src_prepare() {
}
src_configure() {
+ # Libav was replaced in 1.2 with ffmpeg by default
+ # but I've elected to not make people change their use flags for AAC
+ # as its the same code anyway
./configure \
--force \
--verbose \
--prefix="${EPREFIX}/usr" \
--disable-gtk-update-checks \
- $(use_enable libav-aac) \
+ --disable-flatpak \
+ --disable-gtk4 \
+ $(use_enable libav-aac ffmpeg-aac) \
$(use_enable fdk fdk-aac) \
- $(use_enable gtk) \
+ $(usex !gtk --disable-gtk) \
$(usex !gstreamer --disable-gst) \
+ $(use_enable nvenc) \
$(use_enable x265) || die "Configure failed."
}
@@ -137,10 +144,14 @@ src_install() {
}
pkg_postinst() {
- einfo "For the CLI version of HandBrake, you can use \`HandBrakeCLI\`."
+ einfo "Gentoo builds of HandBrake are NOT SUPPORTED by upstream as they"
+ einfo "do not use the bundled (and often patched) upstream libraries."
+ einfo ""
+ einfo "Please do not raise bugs with upstream because of these ebuilds,"
+ einfo "report bugs to Gentoo's bugzilla or Multimedia forum instead."
+ einfo "For the CLI version of HandBrake, you can use \`HandBrakeCLI\`."
if use gtk ; then
- einfo ""
einfo "For the GTK+ version of HandBrake, you can run \`ghb\`."
fi