summaryrefslogtreecommitdiff
path: root/media-video/mpeg2vidcodec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /media-video/mpeg2vidcodec
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'media-video/mpeg2vidcodec')
-rw-r--r--media-video/mpeg2vidcodec/Manifest4
-rw-r--r--media-video/mpeg2vidcodec/files/mpeg2vidcodec-12-Wimplicit-function-declaration.patch54
-rw-r--r--media-video/mpeg2vidcodec/files/mpeg2vidcodec-12-fix-build-system.patch78
-rw-r--r--media-video/mpeg2vidcodec/mpeg2vidcodec-12-r1.ebuild24
4 files changed, 146 insertions, 14 deletions
diff --git a/media-video/mpeg2vidcodec/Manifest b/media-video/mpeg2vidcodec/Manifest
index 515e2fce9780..bf1510b727cd 100644
--- a/media-video/mpeg2vidcodec/Manifest
+++ b/media-video/mpeg2vidcodec/Manifest
@@ -1,3 +1,5 @@
+AUX mpeg2vidcodec-12-Wimplicit-function-declaration.patch 1020 BLAKE2B b61c8c45a0a3fa499e6f7c153cced71c80a87d6ddeda0283d51c56932393eb994297f7f192fffa342d952547b6857c8ead2d8aa1a99202c4d3c19ef8adf5cc02 SHA512 2741e393adadc6b74408b53dd978b820ed80483eb8c91ce1b50f2e916bdcaef7c25fb8679e4c8fad5686f0da99c42881738f424e72b2a02a2d098f0d2f99b393
+AUX mpeg2vidcodec-12-fix-build-system.patch 2038 BLAKE2B cb5dedb4c2c4a60e85e23cebabe12d6c6ec95ba3ba5b198da99735e515ff78007aa40b67be87e23d3ab2558b40c390f944417dbcf72a3026550683bb8297bf61 SHA512 04d55902b48f68460e5272a5ddacf1f6b9f1dbe2f3fa4b9955e804a1ae36f533998f51eb1cdae7f9babbcd753d3436b71d37af324f2eac3bf02c9df6f64e99d7
DIST mpeg2vidcodec_v12.tar.gz 259790 BLAKE2B 528a6bc7ffdf25ff97241752d26accf83860f3dcf6a7f8ce9394308c1cb1ece0cad9d79f8a6ce7b59823900e9ff991a1cc0ff9de8c11749736576d847d07545a SHA512 2a46f486102ac2a1ae99a0f75b196c5aa01f8a99a6230723a2000ca8411adbca6c3e07d70f7cb269b17ce5fa4bf318e6dd4bfa83ecf8e137e8efca2bb352735c
-EBUILD mpeg2vidcodec-12-r1.ebuild 819 BLAKE2B 35eb7318a4e038d5839c098c8df44c780b9ebfb5360ba8b9aa8950cd0beaf4283020420f90585ef667429624c2c83534c3ce016cd9fb0851373d23e08f2ac4a3 SHA512 305bd5edac08bf2447b3cdab9d16ded6151021312574e3a6b58c14c77fdf035c2ddedfaf8bdec6dbcb9d3848f01f832f7f3e18bc19d2264927ff179094a0e2b4
+EBUILD mpeg2vidcodec-12-r1.ebuild 734 BLAKE2B f6f926944da5c386c05b3295607eef66b67dc3b28b958438df6ce5f13a1bfdbcbc7d07c528ea4a19f450ee5e6f1faf82f7bd249e8a321009d6f3fe1ee3cdf51c SHA512 8449e75e6e128e23d41ae3eca6d1f7e563686f52be3db1002d3b6d02f85f0f0bc0fdf766be6f053a0fdaa65fc5efd7fcbd50a26d506ce3e13e346139cb533305
MISC metadata.xml 221 BLAKE2B dbd3c4ca4e95a1ad33f79e707799593ad704252f4f1c17e08c7e42ede0e4ad153eb659fc130717823dad18cab485c7b941a7089d2d964b96d2e2f7c5f1ba8df2 SHA512 e5a88aac41d38b1bdf0becef8d0a08d1875eb803fac3f791524a7810c8068cfd2239a42717bddf9835daf6c0b2c5d5592b12669882bbc2abaab39955d7de7fb4
diff --git a/media-video/mpeg2vidcodec/files/mpeg2vidcodec-12-Wimplicit-function-declaration.patch b/media-video/mpeg2vidcodec/files/mpeg2vidcodec-12-Wimplicit-function-declaration.patch
new file mode 100644
index 000000000000..7f618a2e9f8d
--- /dev/null
+++ b/media-video/mpeg2vidcodec/files/mpeg2vidcodec-12-Wimplicit-function-declaration.patch
@@ -0,0 +1,54 @@
+--- a/src/mpeg2dec/getbits.c
++++ b/src/mpeg2dec/getbits.c
+@@ -34,6 +34,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <unistd.h>
+
+ #include "config.h"
+ #include "global.h"
+--- a/src/mpeg2dec/mpeg2dec.c
++++ b/src/mpeg2dec/mpeg2dec.c
+@@ -32,6 +32,8 @@
+ #include <stdlib.h>
+ #include <ctype.h>
+ #include <fcntl.h>
++#include <sys/types.h>
++#include <unistd.h>
+
+ #define GLOBAL
+ #include "config.h"
+--- a/src/mpeg2dec/spatscal.c
++++ b/src/mpeg2dec/spatscal.c
+@@ -1,5 +1,7 @@
+
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include "config.h"
+ #include "global.h"
+
+--- a/src/mpeg2dec/store.c
++++ b/src/mpeg2dec/store.c
+@@ -28,8 +28,10 @@
+ */
+
+ #include <stdio.h>
++#include <string.h>
+ #include <stdlib.h>
+ #include <fcntl.h>
++#include <unistd.h>
+
+ #include "config.h"
+ #include "global.h"
+--- a/src/mpeg2dec/subspic.c
++++ b/src/mpeg2dec/subspic.c
+@@ -31,6 +31,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <fcntl.h>
++#include <unistd.h>
+
+ #include "config.h"
+ #include "global.h"
diff --git a/media-video/mpeg2vidcodec/files/mpeg2vidcodec-12-fix-build-system.patch b/media-video/mpeg2vidcodec/files/mpeg2vidcodec-12-fix-build-system.patch
new file mode 100644
index 000000000000..e278b3a26d76
--- /dev/null
+++ b/media-video/mpeg2vidcodec/files/mpeg2vidcodec-12-fix-build-system.patch
@@ -0,0 +1,78 @@
+--- a/Makefile
++++ b/Makefile
+@@ -53,26 +53,23 @@
+ #
+ # GNU gcc
+ #
+-CC = gcc
+-CFLAGS = -O2
++CFLAGS += -Wall
+
+ all: mpeg2decode mpeg2encode
+
+ mpeg2decode:
+- cd src/mpeg2dec; make 'CC=$(CC)' \
+- 'CFLAGS=$(CFLAGS) $(USE_DISP) $(USE_SHMEM) $(INCLUDEDIR)' \
+- 'LIBS=$(LIBS)' 'LIBRARYDIR=$(LIBRARYDIR)'
++ cd src/mpeg2dec && $(MAKE)
+
+ mpeg2encode:
+- cd src/mpeg2enc; make 'CC=$(CC)' 'CFLAGS=$(CFLAGS)'
++ cd src/mpeg2enc && $(MAKE)
+
+ pc:
+- cd src/mpeg2dec; make pc 'CC=$(CC)' 'CFLAGS=$(CFLAGS)'
+- cd src/mpeg2enc; make pc 'CC=$(CC)' 'CFLAGS=$(CFLAGS)'
++ cd src/mpeg2dec && $(MAKE) pc
++ cd src/mpeg2enc && $(MAKE) pc
+
+ clean:
+- cd src/mpeg2dec; make clean
+- cd src/mpeg2enc; make clean
++ cd src/mpeg2dec && $(MAKE) clean
++ cd src/mpeg2enc && $(MAKE) clean
+
+ test:
+ cd verify; ./verify
+--- a/src/mpeg2dec/Makefile
++++ b/src/mpeg2dec/Makefile
+@@ -60,8 +60,7 @@
+ #
+ # GNU gcc
+ #
+-CC = gcc
+-CFLAGS = -O2 $(USE_DISP) $(USE_SHMEM) $(INCLUDEDIR) $(TRACE) $(VERBOSE) $(VERIFY) $(WARNINGS)
++CFLAGS += -Wall
+
+ OBJ = mpeg2dec.o getpic.o motion.o getvlc.o gethdr.o getblk.o getbits.o store.o recon.o spatscal.o idct.o idctref.o display.o systems.o subspic.o verify.o
+
+@@ -76,7 +75,7 @@
+ coff2exe mpeg2dec
+
+ mpeg2decode: $(OBJ)
+- $(CC) $(CFLAGS) $(LIBRARYDIR) -o mpeg2decode $(OBJ) -lm $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $(LIBRARYDIR) -o mpeg2decode $(OBJ) -lm $(LIBS)
+
+ display.o : display.c config.h global.h mpeg2dec.h
+ getbits.o : getbits.c config.h global.h mpeg2dec.h
+--- a/src/mpeg2enc/Makefile
++++ b/src/mpeg2enc/Makefile
+@@ -32,8 +32,7 @@
+ #
+ # GNU gcc
+ #
+-CC = gcc
+-CFLAGS = -O2 -Wall
++CFLAGS += -Wall
+
+ OBJ = mpeg2enc.o conform.o putseq.o putpic.o puthdr.o putmpg.o putvlc.o putbits.o motion.o predict.o readpic.o writepic.o transfrm.o fdctref.o idct.o quantize.o ratectl.o stats.o
+
+@@ -48,7 +47,7 @@
+ coff2exe mpeg2enc
+
+ mpeg2encode: $(OBJ)
+- $(CC) $(CFLAGS) -o mpeg2encode $(OBJ) -lm
++ $(CC) $(CFLAGS) $(LDFLAGS) -o mpeg2encode $(OBJ) -lm
+
+ conform.o : conform.c config.h global.h mpeg2enc.h
+ fdctref.o : fdctref.c config.h
diff --git a/media-video/mpeg2vidcodec/mpeg2vidcodec-12-r1.ebuild b/media-video/mpeg2vidcodec/mpeg2vidcodec-12-r1.ebuild
index d3769dd81efc..33d9cdb700f6 100644
--- a/media-video/mpeg2vidcodec/mpeg2vidcodec-12-r1.ebuild
+++ b/media-video/mpeg2vidcodec/mpeg2vidcodec-12-r1.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
inherit toolchain-funcs
MY_P="${PN}_v${PV}"
+
DESCRIPTION="MPEG Library"
HOMEPAGE="http://www.mpeg.org/"
SRC_URI="http://www.mpeg.org/pub_ftp/mpeg/mssg/${MY_P}.tar.gz"
@@ -13,23 +14,20 @@ SRC_URI="http://www.mpeg.org/pub_ftp/mpeg/mssg/${MY_P}.tar.gz"
LICENSE="mpeg2enc"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
-IUSE=""
RESTRICT="mirror bindist" #465088
-S=${WORKDIR}/mpeg2
-
-src_prepare() {
- sed -i -e 's:make:$(MAKE):' Makefile || die
+S="${WORKDIR}/mpeg2"
- sed -i -e 's:$(CC) $(CFLAGS):\0 $(LDFLAGS):' \
- src/mpeg2enc/Makefile src/mpeg2dec/Makefile || die
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-build-system.patch
+ "${FILESDIR}"/${P}-Wimplicit-function-declaration.patch
+)
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+src_configure() {
+ tc-export CC
}
src_install() {
dobin src/mpeg2dec/mpeg2decode src/mpeg2enc/mpeg2encode
- dodoc README doc/*
+ dodoc -r README doc/.
}