summaryrefslogtreecommitdiff
path: root/media-video/mplay-sh/mplay-sh-0.5.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-video/mplay-sh/mplay-sh-0.5.3-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-video/mplay-sh/mplay-sh-0.5.3-r1.ebuild')
-rw-r--r--media-video/mplay-sh/mplay-sh-0.5.3-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-video/mplay-sh/mplay-sh-0.5.3-r1.ebuild b/media-video/mplay-sh/mplay-sh-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..d9e424343ed1
--- /dev/null
+++ b/media-video/mplay-sh/mplay-sh-0.5.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils
+
+MY_P="mplay-${PV}"
+
+DESCRIPTION="mplayer wrapper script as backend for vdr-mplayer"
+HOMEPAGE="http://www.vdr-portal.de/board/thread.php?threadid=62306"
+SRC_URI="mirror://gentoo/${MY_P}.tgz
+ https://dev.gentoo.org/~zzam/distfiles/${MY_P}.tgz"
+
+KEYWORDS="x86 ~amd64"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="media-tv/gentoo-vdr-scripts"
+RDEPEND=">=media-video/mplayer-0.90_rc4"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i mplay.sh \
+ -e 's#$CONFDIR/silence.wav#/usr/share/vdr/mplay-sh/silence.wav#'
+ sed -i conf.examples/mplayrc \
+ -e 's#^MPLAY_PLAY.*#MPLAY_PLAY="/var/vdr/tmp/mplay.play"#'
+}
+
+src_install() {
+ exeinto /usr/share/vdr/mplayer/bin
+ doexe mplay.sh
+
+ insinto /etc/vdr/plugins/mplay
+ doins conf.examples/*.conf conf.examples/mplayrc
+
+ insinto /usr/share/vdr/mplay-sh
+ doins conf.examples/silence.wav
+
+ dodoc README* HISTORY
+ keepdir /var/vdr/tmp
+ chown vdr:vdr -R "${D}/var/vdr"
+}