summaryrefslogtreecommitdiff
path: root/media-video/obs-studio/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
commit7014a5a3ea0feffab9701fdd6b64cc7667a985af (patch)
treef2cbbaa8bb9209cd15208721103228336149b799 /media-video/obs-studio/files
parent7a86906b67693cc65671d3e1476835d3a7e13092 (diff)
gentoo resync : 30.06.2019
Diffstat (limited to 'media-video/obs-studio/files')
-rw-r--r--media-video/obs-studio/files/obs-studio-23.2.1-use-correct-libdir.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/media-video/obs-studio/files/obs-studio-23.2.1-use-correct-libdir.patch b/media-video/obs-studio/files/obs-studio-23.2.1-use-correct-libdir.patch
new file mode 100644
index 000000000000..619c414d6b8a
--- /dev/null
+++ b/media-video/obs-studio/files/obs-studio-23.2.1-use-correct-libdir.patch
@@ -0,0 +1,50 @@
+From ab67b39257be83eaab87c4a938c4c58b5cccad7e Mon Sep 17 00:00:00 2001
+From: Jimi Huotari <chiitoo@gentoo.org>
+Date: Fri, 21 Jun 2019 17:48:32 +0300
+Subject: [PATCH] cmake: Install 'libobs.pc' under the correct 'libdir'
+
+In 'libobs/CMakeLists.txt', use '${CMAKE_INSTALL_LIBDIR}' instead of
+'${CMAKE_INSTALL_PREFIX}/lib', as the latter results into 'libobs.pc'
+being installed under '/lib' when '/lib64' would be more appropriate.
+
+In 'libobs/libobs.pc.in', use '@CMAKE_INSTALL_FULL_LIBDIR@' for
+'libdir', '@CMAKE_INSTALL_FULL_INCLUDEDIR@' for 'includedir',
+and '@CMAKE_INSTALL_PREFIX@' for 'prefix'.
+
+Gentoo-Bug: https://bugs.gentoo.org/644538
+---
+ libobs/CMakeLists.txt | 2 +-
+ libobs/libobs.pc.in | 6 +++---
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/libobs/CMakeLists.txt b/libobs/CMakeLists.txt
+index fed3e694..86811481 100644
+--- a/libobs/CMakeLists.txt
++++ b/libobs/CMakeLists.txt
+@@ -454,7 +454,7 @@ if(UNIX AND NOT APPLE)
+ set(PRIVATE_LIBS "${PRIVATE_LIBS} -l${LIB}")
+ endforeach()
+ CONFIGURE_FILE("libobs.pc.in" "libobs.pc" @ONLY)
+- install(FILES "${CMAKE_CURRENT_BINARY_DIR}/libobs.pc" DESTINATION "${CMAKE_INSTALL_PREFIX}/lib/pkgconfig")
++ install(FILES "${CMAKE_CURRENT_BINARY_DIR}/libobs.pc" DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig")
+ endif()
+
+ set_target_properties(libobs PROPERTIES
+diff --git a/libobs/libobs.pc.in b/libobs/libobs.pc.in
+index 03fe4cdd..f6c471ba 100644
+--- a/libobs/libobs.pc.in
++++ b/libobs/libobs.pc.in
+@@ -1,7 +1,7 @@
+-prefix=@DEST_DIR@
++prefix=@CMAKE_INSTALL_PREFIX@
+ exec_prefix=${prefix}
+-libdir=${prefix}/@OBS_LIBRARY_DESTINATION@
+-includedir=${prefix}/include
++libdir=@CMAKE_INSTALL_FULL_LIBDIR@
++includedir=@CMAKE_INSTALL_FULL_INCLUDEDIR@
+
+ Name: libobs
+ Description: OBS Studio Library
+--
+2.22.0
+