summaryrefslogtreecommitdiff
path: root/media-video/shotcut
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-04 18:55:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-04 18:55:01 +0000
commit423d21dcfee183cc4b04d29c1621615e8c30f834 (patch)
tree23bd6110b9a77b8d679b5ab60fb7663b8627f698 /media-video/shotcut
parent81e4fbcb846ed1cabdad699c0029b166dd7273b7 (diff)
gentoo resync : 04.01.2018
Diffstat (limited to 'media-video/shotcut')
-rw-r--r--media-video/shotcut/Manifest3
-rw-r--r--media-video/shotcut/metadata.xml15
-rw-r--r--media-video/shotcut/shotcut-18.01.ebuild64
3 files changed, 82 insertions, 0 deletions
diff --git a/media-video/shotcut/Manifest b/media-video/shotcut/Manifest
new file mode 100644
index 000000000000..5bc984a812fc
--- /dev/null
+++ b/media-video/shotcut/Manifest
@@ -0,0 +1,3 @@
+DIST shotcut-18.01.tar.gz 4027948 BLAKE2B cbc82eac35b3d378bd0da6857f80fddf758e17d82d5be25224716769d51afc9a37ecd5395f0599fc421d6190d6a426ad2f9ab222fb3871f9e5e07b11465d38a4 SHA512 d36843eeb6f2906f3b9f546b24e691754984897bda74618ebebd85bb7e32f97d951d55bc6dcf6f2b0f1c1ab39ee1180de5b44e7022ee2fe9b687e3cb4b9bada3
+EBUILD shotcut-18.01.ebuild 1292 BLAKE2B 2d7174083270ce131699b0fa62a447882db5f13855cf190840b62d665088e14a8ccc48defa398a96228a8d432114d4ffd75da6cc03757c0bc2c400c2c1dc4c62 SHA512 ef096315ed12b2b79846cd38db2423a3c89ea0b833b293db1b18f78f23450a87cadac12ef38a0e006df8361682991cadce77d6fa454cf0831753a3cc2bc3530c
+MISC metadata.xml 451 BLAKE2B 7438699cd72f469998316ff1f3efd8bda67aab68f0fdbd405bb24b286e75f998a82b88c01c7d74d63fadeec47f58c381c51652854ac3dc8bd6a3a687fb8cb42f SHA512 58f1a6ddd5eef3a6cfd81936d61e34ea29aa7a26e5e841e96218642fa9fafc5529c3c6e0283f8c1e948a11eb819163e03056335d989933f390854f22aeb61ed0
diff --git a/media-video/shotcut/metadata.xml b/media-video/shotcut/metadata.xml
new file mode 100644
index 000000000000..9fca7f80ebad
--- /dev/null
+++ b/media-video/shotcut/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>reagentoo@gmail.com</email>
+ <name>Dmitry Baranov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mltframework/shotcut</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/shotcut/shotcut-18.01.ebuild b/media-video/shotcut/shotcut-18.01.ebuild
new file mode 100644
index 000000000000..3367892ca51e
--- /dev/null
+++ b/media-video/shotcut/shotcut-18.01.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop qmake-utils
+
+DESCRIPTION="A free, open source, cross-platform video editor"
+HOMEPAGE="https://www.shotcut.org/"
+SRC_URI="https://github.com/mltframework/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtsql:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ media-libs/ladspa-sdk
+ media-libs/libsdl:0
+ media-libs/libvpx
+ media-libs/mlt[ffmpeg,frei0r,qt5,sdl,xml]
+ media-libs/x264
+ media-plugins/frei0r-plugins
+ media-sound/lame
+ media-video/ffmpeg
+ virtual/jack
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+src_prepare() {
+ local mylrelease="$(qt5_get_bindir)/lrelease"
+ "${mylrelease}" "${S}/src/src.pro" || die "preparing locales failed"
+
+ default
+}
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+
+ newicon "${S}/icons/shotcut-logo-64.png" "${PN}.png"
+ make_desktop_entry shotcut "Shotcut"
+
+ insinto "/usr/share/${PN}/translations"
+ doins translations/*.qm
+
+ einstalldocs
+}