summaryrefslogtreecommitdiff
path: root/media-video/snappy/snappy-1.0_p20200428.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /media-video/snappy/snappy-1.0_p20200428.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'media-video/snappy/snappy-1.0_p20200428.ebuild')
-rw-r--r--media-video/snappy/snappy-1.0_p20200428.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-video/snappy/snappy-1.0_p20200428.ebuild b/media-video/snappy/snappy-1.0_p20200428.ebuild
new file mode 100644
index 000000000000..572a173dfe7c
--- /dev/null
+++ b/media-video/snappy/snappy-1.0_p20200428.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME2_EAUTORECONF="yes"
+
+inherit gnome2
+
+DESCRIPTION="A simple media player written using GStreamer and Clutter"
+HOMEPAGE="https://wiki.gnome.org/Apps/Snappy"
+COMMIT_HASH="ebf8e3ed30013e6577fa8994db40743d2ec05e94"
+SRC_URI="https://gitlab.gnome.org/GNOME/snappy/-/archive/${COMMIT_HASH}/snappy-${COMMIT_HASH}.tar.bz2"
+S="${WORKDIR}/${PN}-${COMMIT_HASH}"
+
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=media-libs/clutter-1.20.0:1.0
+ media-libs/clutter-gst:3.0
+ >=media-libs/clutter-gtk-1.6.0:1.0
+ >=x11-libs/gtk+-3.5.0:3
+ x11-libs/libXtst
+
+ >=media-libs/gstreamer-1.6.0:1.0
+ >=media-libs/gst-plugins-base-1.6.0:1.0
+
+ media-plugins/gst-plugins-meta:1.0
+
+ !!<net-misc/spice-gtk-0.19
+" # File collision -- /usr/bin/snappy with older versions
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ DOCS="AUTHORS README THANKS ToDo docs/*"
+ gnome2_src_configure --enable-dbus
+}