summaryrefslogtreecommitdiff
path: root/media-video/totem
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /media-video/totem
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'media-video/totem')
-rw-r--r--media-video/totem/Manifest1
-rw-r--r--media-video/totem/totem-3.34.1-r1.ebuild119
2 files changed, 120 insertions, 0 deletions
diff --git a/media-video/totem/Manifest b/media-video/totem/Manifest
index 14193f4c673b..295cb61ae081 100644
--- a/media-video/totem/Manifest
+++ b/media-video/totem/Manifest
@@ -1,4 +1,5 @@
AUX 3.34.1-gst-inspect-sandbox.patch 1828 BLAKE2B 9abd87afc62c784c4e5f79374d0172da0295cee520a9aa3ce2d4a2471f3e94accd7f14746fb93873767a5a11a2c9143b9387bf70295cc792199df62f501f73de SHA512 c312ddee62695b4344917eb2c7cca67284f3c7b24b21f35646f8b315bded9827aec05056fd17eadfe35da3dd876f20fd7b2cadd2141d04843c3c96d5f0346b21
DIST totem-3.34.1.tar.xz 2157160 BLAKE2B 9ae9c8f6485c7377af07803c328e8ea3cc6fa80d8e30a7045bd2b50f7bc3d5a12582e5b60d901d22683f89e994c619c26ddb8b0890e343c873d4457fa177786d SHA512 9a3556f5cf522fca29926db185c2e5d25bdb80a25e14d0ba3062a7f15fc3ec40ae9f25752763bc444d4fd82ec2098efd732da662a1b1c5923ec19fde432606db
+EBUILD totem-3.34.1-r1.ebuild 2791 BLAKE2B aeed204e0cd252f1445fb9d97106d3e1c027352241bb5ea9f1bddb52dd9dd90016cc01020e7c40756aed4882c7d8df387ed5cd541d3a177b31db4e7510abd541 SHA512 051c6aed8c037fa27d4ad42da24a2aac4f98d79fe5edd8ae3372baa470761da49ac3df8cb8bc63f9623ff4b081c3ae64d6c4aae469c3bf3b6c3da7602bda3114
EBUILD totem-3.34.1.ebuild 2787 BLAKE2B aa2b12503566a4bd278e0dc62e4e5a81043e7ae5eb1ea08e12f949ae466fc26fc107d9119ba1e117fd7c222bb06a396096e612c064b72dcd9698fc5b810ef797 SHA512 0b2878f608208b6a57e47e0db21e604631ee9438d064b667c287cbcc0d28b404652c5127215f9c801916d747e1fc48ee9fcb509c43dfa86f64ee3ca88998553e
MISC metadata.xml 1017 BLAKE2B de40f52bc4cc3c838b473d4c444e9c41673cd3c2925f17508d03f5130fe237784d4ee4d02581718c06ccd30fa204d27ba7691fb8046009a540c00f3535f6909d SHA512 9b89a8eaa90ad2f55abf7a53bfba7c065be999233a7bbfe243f4514ca1c3ec5a3934f23ea8ecd6b2674ac82d5e55e2f3e25e3869a0cec019485c9bb99549b625
diff --git a/media-video/totem/totem-3.34.1-r1.ebuild b/media-video/totem/totem-3.34.1-r1.ebuild
new file mode 100644
index 000000000000..afdbd33dcf83
--- /dev/null
+++ b/media-video/totem/totem-3.34.1-r1.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit gnome.org gnome2-utils meson virtualx xdg python-single-r1
+
+DESCRIPTION="Media player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Videos"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="gtk-doc +python test"
+# see bug #359379
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+RESTRICT="!test? ( test )"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.43.4:2
+ >=x11-libs/gtk+-3.19.4:3[introspection]
+ >=media-libs/gstreamer-1.6.0:1.0
+ >=media-libs/gst-plugins-base-1.6.0:1.0[pango]
+ >=media-libs/gst-plugins-good-1.6.0:1.0
+ >=media-libs/grilo-0.3.0:0.3[playlist]
+ >=dev-libs/libpeas-1.1.0[gtk]
+ >=dev-libs/totem-pl-parser-3.10.1:0=[introspection]
+ >=media-libs/clutter-1.17.3:1.0[gtk]
+ >=media-libs/clutter-gst-2.99.2:3.0
+ >=media-libs/clutter-gtk-1.8.1:1.0
+ gnome-base/gnome-desktop:3=
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/cairo-1.14
+ x11-libs/gdk-pixbuf:2
+ >=dev-libs/gobject-introspection-1.54:=
+
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ media-plugins/grilo-plugins:0.3
+ media-plugins/gst-plugins-meta:1.0
+ media-plugins/gst-plugins-taglib:1.0
+ x11-themes/adwaita-icon-theme
+ python? (
+ x11-libs/pango[introspection]
+ >=dev-libs/libpeas-1.1.0[python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
+"
+BDEPEND="
+ dev-lang/perl
+ gtk-doc? ( >=dev-util/gtk-doc-1.14
+ app-text/docbook-xml-dtd:4.5 )
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+# perl for pod2man
+# Prevent dev-python/pylint dep, bug #482538
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-gst-inspect-sandbox.patch # Allow disabling calls to gst-inspect (sandbox issue)
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Drop pointless samplepython plugin from build
+ sed -e '/samplepython/d' -i src/plugins/meson.build || die
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Denable-easy-codec-installation=yes
+ -Denable-python=$(usex python yes no)
+ -Dwith-plugins=all # in 3.34.1 only builtin and python plugins are left, and python is extra controlled by enable-python
+ $(meson_use gtk-doc enable-gtk-doc)
+ -Dgst-inspect=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use python ; then
+ python_optimize "${ED}"/usr/$(get_libdir)/totem/plugins/
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
+
+src_test() {
+ virtx meson_src_test
+}