summaryrefslogtreecommitdiff
path: root/media-video/vidify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /media-video/vidify
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'media-video/vidify')
-rw-r--r--media-video/vidify/Manifest3
-rw-r--r--media-video/vidify/metadata.xml24
-rw-r--r--media-video/vidify/vidify-2.2.6.ebuild80
3 files changed, 107 insertions, 0 deletions
diff --git a/media-video/vidify/Manifest b/media-video/vidify/Manifest
new file mode 100644
index 000000000000..b75a8a54c4dc
--- /dev/null
+++ b/media-video/vidify/Manifest
@@ -0,0 +1,3 @@
+DIST vidify-2.2.6.tar.gz 2906511 BLAKE2B 3df48ca57e102f664852e2fc2abeb3d19427673e1fec5144a8c0afda112a0f3b281b18db43b4326244266d6e9dfbcb2443319ddad3f864098a61bd1e3c966307 SHA512 15487ee9dcbe647b2b287bd2eb3c09962b557320313a9a3885fb3c0d6af945909531111d5297c1a5fb5b451af5df6fd968b3953bbf79af113980ed368a5674b5
+EBUILD vidify-2.2.6.ebuild 2337 BLAKE2B 75c915d511a7ab1d0987633932ddbfbc35c011c614c4b302943ee9dd5e36b25036f4a2881105433f17623e608d89fa9dad9c558484b4ab8554e7a3ef0c20d152 SHA512 f65f7d4fa6aac96ac88fb05704f89e470aee7da43d1e02c10bc90b6773123a5aa00b65a0e09d26500d463a30a9a594b121440e02bd7d3145ba9e2b4320857306
+MISC metadata.xml 791 BLAKE2B 58d9b11d25213a1666a2c7bb10fcf8a717c9c9ac3dcd8b7a158ca0a61236ee33252ba82d2f6ae5b53d649320563929f5661a12c64ea6420ca378708e5161661a SHA512 8483e3fe402371289ee636e7001ee44844a40cc0c640507be6b806a2b88672e424a1a9bb4e987a15658e57abab9541e684c16ee08779f0a471388aa5270dae7f
diff --git a/media-video/vidify/metadata.xml b/media-video/vidify/metadata.xml
new file mode 100644
index 000000000000..7f12ddb07a53
--- /dev/null
+++ b/media-video/vidify/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <use>
+ <flag name="vlc">Use python-vlc as backend for vidify</flag>
+ <flag name="mpv">Use python-mpv as backend for vidify</flag>
+ <flag name="zeroconf">Use an external network player</flag>
+ <flag name="dbus">Support local MPRIS players</flag>
+ </use>
+ <upstream>
+ <maintainer>
+ <email>marioortizmanero@gmail.com</email>
+ <name>Mario Ortiz Manero</name>
+ </maintainer>
+ <remote-id type="github">vidify/vidify</remote-id>
+ <bugs-to>https://github.com/vidify/vidify/issues</bugs-to>
+ </upstream>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/media-video/vidify/vidify-2.2.6.ebuild b/media-video/vidify/vidify-2.2.6.ebuild
new file mode 100644
index 000000000000..d80a08f97932
--- /dev/null
+++ b/media-video/vidify/vidify-2.2.6.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit xdg distutils-r1 optfeature virtualx
+
+DESCRIPTION="Watch music videos in real time for the songs playing on your device"
+HOMEPAGE="https://vidify.org"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="dbus vlc mpv zeroconf"
+
+REQUIRED_USE="|| ( vlc mpv zeroconf )"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/QtPy[gui,webengine,${PYTHON_USEDEP}]
+ net-misc/lyricwikia[${PYTHON_USEDEP}]
+ net-misc/youtube-dl[${PYTHON_USEDEP}]
+ dbus? ( dev-python/pydbus[${PYTHON_USEDEP}] )
+ !dbus? ( dev-python/tekore[${PYTHON_USEDEP}] )
+ mpv? ( dev-python/python-mpv[${PYTHON_USEDEP}] )
+ vlc? ( dev-python/python-vlc[${PYTHON_USEDEP}] )
+ zeroconf? ( dev-python/zeroconf[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # skip online test
+ rm tests/api/test_spotify_web.py || die
+ rm tests/player/test_external.py || die
+
+ # this needs dbus and a player running
+ rm tests/api/test_mpris.py || die
+
+ # can't parse non-existent config
+ rm tests/test_api_and_player_data.py || die
+
+ # do not hard depend on this
+ sed -i \
+ -e '/qdarkstyle/d' \
+ -e '/python-vlc/d' \
+ -e '/python-mpv/d' \
+ -e '/pydbus/d' \
+ -e '/tekore/d' \
+ -e '/zeroconf/d' \
+ -e '/If PySide2 is installed and PyQt5/,/PyQtWebEngine/d' \
+ setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ virtx "${EPYTHON}" -m unittest discover -v
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "If video playback is not working please check 'vidify --debug' for missing-codec-errors"
+ elof "and recompile media-video/vlc or media-video/mpv with the missing codecs"
+
+ optfeature "using an MPRIS(D-Bus) audio player (e.g spotify)" dev-python/pydbus
+ optfeature "using the Spotify Web API as audio player" dev-python/tekore
+ optfeature "using an external network player" dev-python/zeroconf
+ optfeature "using media-video/mpv for video playback" dev-python/python-mpv
+ optfeature "using media-video/vlc for video playback" dev-python/python-vlc
+ optfeature "'vidify --dark-mode'" dev-python/qdarkstyle
+ optfeature "'vidify --audiosync'" media-video/vidify-audiosync
+}