summaryrefslogtreecommitdiff
path: root/media-video/vstrip/vstrip-0.8f.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /media-video/vstrip/vstrip-0.8f.ebuild
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'media-video/vstrip/vstrip-0.8f.ebuild')
-rw-r--r--media-video/vstrip/vstrip-0.8f.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/media-video/vstrip/vstrip-0.8f.ebuild b/media-video/vstrip/vstrip-0.8f.ebuild
index ebf44df3a614..7aa923068945 100644
--- a/media-video/vstrip/vstrip-0.8f.ebuild
+++ b/media-video/vstrip/vstrip-0.8f.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
inherit eutils toolchain-funcs
@@ -15,24 +15,23 @@ KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
DEPEND="app-arch/unzip"
-RDEPEND=""
S="${WORKDIR}/${PN}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-gentoo.patch
+src_prepare() {
+ eapply "${FILESDIR}"/${P}-gentoo.patch
edos2unix *.c *.h
- for file in *.c *.h ; do
- echo >>$file
+ local f
+ for f in *.c *.h ; do
+ echo >> "${f}" || die
done
+
+ default
}
src_compile() {
- emake CFLAGS="${CFLAGS} -D__UNIX__" CC="$(tc-getCC)" || die "emake failed."
+ emake CFLAGS="${CFLAGS} -D__UNIX__" CC="$(tc-getCC)"
}
src_install() {