summaryrefslogtreecommitdiff
path: root/media-video/yle-dl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /media-video/yle-dl
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'media-video/yle-dl')
-rw-r--r--media-video/yle-dl/Manifest2
-rw-r--r--media-video/yle-dl/yle-dl-20200419.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/media-video/yle-dl/Manifest b/media-video/yle-dl/Manifest
index 8c24a86218a7..cae2503fd928 100644
--- a/media-video/yle-dl/Manifest
+++ b/media-video/yle-dl/Manifest
@@ -1,3 +1,5 @@
DIST yle-dl-20200222.tar.gz 87059 BLAKE2B 25d645505d67d71b3662589c77c30f905ded81e2d64874cf6036dcaf0738e521e96650543a78c18031a4477fc3bcf121e7497c980d22c84e21bebc2bd7cb154a SHA512 2b4a98c19a12812bc3c00de6173d50c78c981de0186c29021c8d88349ae88759a4987f6488d758ee5397d2b0992cd03029680bb08a4882cb2280a28807d4bf14
+DIST yle-dl-20200419.tar.gz 87267 BLAKE2B 2637620758c1a083502eb9468bbe5e7353855051c3379d448f6a4b9adcf8113293e4a7a8887138df68fcfd16938ab3846034a8f57cb9d366467a22c23b53ebaa SHA512 3d064e080e0c9172e15134eaa179ae96240ed9fc74a7a8a9a9aa18049397e0fea62465f5768db488928f23af1fa1195d78a8a4a6bbafcab4bcda6d05cda70ccf
EBUILD yle-dl-20200222.ebuild 1713 BLAKE2B c6948d5b99001ea73938cb3a79a1b5dc3224bd8d0072b8760eb3c2e7c971a8240e8fc0e1a94cc9d08d8495b886ea766f80b6e78b89b1071420178a7b90d2bda1 SHA512 7e24b218bde4767186d02089202ce55e63d908d432f5cb53fe7f0b46ebde9bed88a24516f997f4bb60959443e2b67bd0928f1065eefcc80bab39f79a616eba51
+EBUILD yle-dl-20200419.ebuild 2011 BLAKE2B d6bb23ecc061d9a73f2701e9fbbc516f6ae5bd2f54e2301f17a304ccab7c3fdb08d0fb13b073742065226d7fc127301976aefaa3657b02b29a2742fdd3c286bb SHA512 d3d46569d76eb1472d6390af7e324c602f2c7281c9027c5bb8f2cb4d86c5287be0694da25518346266d699251570b3eb612b1202991ae503022ba8440fbbd05d
MISC metadata.xml 415 BLAKE2B 3961cdbc02847f65011c6987b811207c31c49ae40c3bea44b481f35ac04e75dabfa8ceae74f6adc816f211129efb8faaa0ba63700d95eec569b3f51cfe64bd42 SHA512 96f1afba4a47f7b5dca75ba1d5300baf9815bdcf3eda12f5b6044aea7cfc09683c76db210a0b4965626aac050016fc39f44c4e5c63597894e0ae6457dc2aeb90
diff --git a/media-video/yle-dl/yle-dl-20200419.ebuild b/media-video/yle-dl/yle-dl-20200419.ebuild
new file mode 100644
index 000000000000..edff6ecff973
--- /dev/null
+++ b/media-video/yle-dl/yle-dl-20200419.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_SINGLE_IMPL=true
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Download media files from Yle Areena"
+HOMEPAGE="https://aajanki.github.io/yle-dl/ https://github.com/aajanki/yle-dl"
+SRC_URI="https://github.com/aajanki/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="libav test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Requires an active internet connection during tests,
+# FEATURES="-network-sandbox" to test.
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}
+ !libav? ( media-video/ffmpeg )
+ net-misc/wget
+ $(python_gen_cond_dep '
+ >=dev-python/attrs-18.1.0[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/configargparse-0.13.0[${PYTHON_MULTI_USEDEP}]
+ dev-python/future[${PYTHON_MULTI_USEDEP}]
+ dev-python/lxml[${PYTHON_MULTI_USEDEP}]
+ dev-python/mini-amf[${PYTHON_MULTI_USEDEP}]
+ dev-python/progress[${PYTHON_MULTI_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ ')
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ media-video/ffmpeg[gnutls]
+ $(python_gen_cond_dep '
+ dev-python/pytest[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
+"
+BDEPEND="${PYTHON_DEPS}"
+
+distutils_enable_tests setup.py
+
+DOCS=( COPYING ChangeLog README.fi README.md yledl.conf.sample )
+
+src_prepare() {
+ default
+
+ # Gentoo doesn't ship pycryptodomex with pycryptodome
+ sed -i 's/pycryptodomex/pycryptodome/g' setup.py || die
+}
+
+src_install() {
+ docompress -x "/usr/share/doc/${PF}/yledl.conf.sample"
+ distutils-r1_src_install
+}
+
+pkg_postinst() {
+ elog "Sample configuration file has been installed to "
+ elog " /usr/share/doc/yle-dl-${PV}/yledl.conf.sample"
+ elog ""
+ elog "Optional download engines: "
+ optfeature "php download engine using rtmpdump" "dev-lang/php:*[bcmath,cli,curl,simplexml] media-video/rtmpdump"
+ optfeature "youtube-dl download engine" net-misc/youtube-dl
+}