summaryrefslogtreecommitdiff
path: root/media-video/yle-dl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /media-video/yle-dl
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'media-video/yle-dl')
-rw-r--r--media-video/yle-dl/Manifest2
-rw-r--r--media-video/yle-dl/yle-dl-20191022.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/media-video/yle-dl/Manifest b/media-video/yle-dl/Manifest
index 315406e431bd..e0afd78eee13 100644
--- a/media-video/yle-dl/Manifest
+++ b/media-video/yle-dl/Manifest
@@ -1,3 +1,5 @@
DIST yle-dl-20190614.tar.gz 83579 BLAKE2B 9117ab32d3e037f22cc209d3686e23d14802438f77203f08e102901d825c06e7c332d1f6ca33bce3af3d4042e9c543fec60e261153be8ab738b038cc1cf4069b SHA512 6a4bfdb93229f48580d8acf742e1e253aa3da79f84ecc3886c32757ddc46608795c58cd02cb0aaa2f7d42188456eac50a243b815baa3752ac6a1b12b9632109c
+DIST yle-dl-20191022.tar.gz 84694 BLAKE2B bfeab9c5220931b8af5eae94b0f5377d21f6b6fb7b21c5f7bc5360a69e7185b8f1e052a584460187cfdd04d68295a20cb895e749af43c1de4ffd7fcd7bfc3875 SHA512 2d7c6d7f8e60cb8fd54fc04dcf73caf5022e3c65ab78f002c280950184fb2458f88f6934b62c0afaeaf30864b5cc47b1ef9c2a58d2855c5111a563cd195095be
EBUILD yle-dl-20190614.ebuild 1750 BLAKE2B 992a1ac48b8554679e3266e9ad3c5d2c5f1e6b293e382fc4a63ae17c1f657a391da6a1e867bc4b8227335d895cd5016d05e0a11862abde2096fcd871287fb7b0 SHA512 73aba786351d47c70450f0b1f54c93727eee82eda4a062c0b58fc3d45e071312413afd34fbe5db975fb204c3e8e309b68043b83ae850db868f9bad562fc9d296
+EBUILD yle-dl-20191022.ebuild 1750 BLAKE2B 7bf27a0871eed096c6831a2e4bd28f1dc3155038b120c645bb8f0e1ae907b1a2c541e2ac5626a82a4c5e02a114c85ff823dd714523bf3f8ab82a0a4baf9edc52 SHA512 2828cb32d0e61a1a1b517d1f5facdeb31736c170ed14981f4418b0b132138d5b454039a917f166afd4aa63f6c8510294d63818699d1fecb5d71c178b8116caf0
MISC metadata.xml 415 BLAKE2B 3961cdbc02847f65011c6987b811207c31c49ae40c3bea44b481f35ac04e75dabfa8ceae74f6adc816f211129efb8faaa0ba63700d95eec569b3f51cfe64bd42 SHA512 96f1afba4a47f7b5dca75ba1d5300baf9815bdcf3eda12f5b6044aea7cfc09683c76db210a0b4965626aac050016fc39f44c4e5c63597894e0ae6457dc2aeb90
diff --git a/media-video/yle-dl/yle-dl-20191022.ebuild b/media-video/yle-dl/yle-dl-20191022.ebuild
new file mode 100644
index 000000000000..281cc2da933d
--- /dev/null
+++ b/media-video/yle-dl/yle-dl-20191022.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5..6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Download media files from Yle Areena"
+HOMEPAGE="http://aajanki.github.io/yle-dl/"
+SRC_URI="https://github.com/aajanki/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="libav php test +youtube-dl"
+
+# Requires an active internet connection during tests
+RESTRICT="test"
+
+RDEPEND="
+ !libav? ( media-video/ffmpeg )
+ >=dev-python/attrs-18.1.0[${PYTHON_USEDEP}]
+ <=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.13.0[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/mini-amf[${PYTHON_USEDEP}]
+ dev-python/progress[${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ net-misc/wget
+ php? (
+ dev-lang/php:*[bcmath,cli,curl,simplexml]
+ >=dev-libs/openssl-1.0.2:0=
+ media-video/rtmpdump
+ )
+ youtube-dl? ( net-misc/youtube-dl[${PYTHON_USEDEP}] )
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( COPYING ChangeLog README.fi README.md yledl.conf.sample )
+
+src_prepare() {
+ default
+
+ # Gentoo doesn't ship pycryptodomex with pycryptodome
+ sed -i 's/pycryptodomex/pycryptodome/g' setup.py || die
+}
+
+python_test() {
+ # For tests to run succesfully, you need to disable network stricting
+ # feature first.
+ # FEATURES="-network-sandbox test" emerge -a yle-dl
+ esetup.py test
+}
+
+pkg_postinst() {
+ einfo "Sample configuration file has been installed in "
+ einfo " /usr/share/doc/yle-dl-2.37/yledl.conf.sample.bz2"
+}