summaryrefslogtreecommitdiff
path: root/net-analyzer/alive/alive-2.0.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-18 15:36:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-18 15:36:15 +0100
commita2f7cdda45fadf1f967379421e8d808b1a503cd3 (patch)
treec02c7db0bb9249243aa73a4098a17e13daaaff21 /net-analyzer/alive/alive-2.0.5-r1.ebuild
parent66611e742171c343d64095516e19737d4753ba61 (diff)
gentoo auto-resync : 18:08:2023 - 15:36:15
Diffstat (limited to 'net-analyzer/alive/alive-2.0.5-r1.ebuild')
-rw-r--r--net-analyzer/alive/alive-2.0.5-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-analyzer/alive/alive-2.0.5-r1.ebuild b/net-analyzer/alive/alive-2.0.5-r1.ebuild
new file mode 100644
index 000000000000..bfa83a170f30
--- /dev/null
+++ b/net-analyzer/alive/alive-2.0.5-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools unpacker
+
+DESCRIPTION="Periodic ping program"
+HOMEPAGE="https://www.gnu.org/software/alive/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+DEPEND="dev-scheme/guile"
+RDEPEND="${DEPEND}
+ dev-scheme/xdgdirs
+ net-misc/iputils"
+BDEPEND="$(unpacker_src_uri_depends)"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.2-ping-test.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}