summaryrefslogtreecommitdiff
path: root/net-analyzer/arping/arping-2.20.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /net-analyzer/arping/arping-2.20.ebuild
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'net-analyzer/arping/arping-2.20.ebuild')
-rw-r--r--net-analyzer/arping/arping-2.20.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-analyzer/arping/arping-2.20.ebuild b/net-analyzer/arping/arping-2.20.ebuild
new file mode 100644
index 000000000000..9f3f308a61fe
--- /dev/null
+++ b/net-analyzer/arping/arping-2.20.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools fcaps
+
+DESCRIPTION="A utility to see if a specific IP address is taken and what MAC address owns it"
+HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=arping"
+SRC_URI="https://github.com/ThomasHabets/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="test"
+
+CDEPEND="
+ net-libs/libpcap
+ net-libs/libnet:1.1
+"
+DEPEND="
+ ${CDEPEND}
+ test? ( dev-libs/check )
+"
+RDEPEND="
+ ${CDEPEND}
+ !net-misc/iputils[arping(+)]
+"
+FILECAPS=( cap_net_raw /usr/sbin/arping )
+S=${WORKDIR}/${PN}-${P}
+
+src_prepare() {
+ default
+ eautoreconf
+}