summaryrefslogtreecommitdiff
path: root/net-analyzer/arpoison
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:00:32 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:00:32 +0100
commitab499d7cfb9ad23e83cf7a4f5052bdf1b4c42030 (patch)
tree2fa77fd80cb0e85ab3e48e6a0558cd3a52ee04c3 /net-analyzer/arpoison
parent5a165c60b9b8c4847067cb83b4be7da785d01f93 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'net-analyzer/arpoison')
-rw-r--r--net-analyzer/arpoison/Manifest2
-rw-r--r--net-analyzer/arpoison/arpoison-0.7.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/arpoison/Manifest b/net-analyzer/arpoison/Manifest
index 49beac77b39d..e1e8b8975de5 100644
--- a/net-analyzer/arpoison/Manifest
+++ b/net-analyzer/arpoison/Manifest
@@ -1,3 +1,5 @@
DIST arpoison-0.6.tar.gz 8646 BLAKE2B 7e9a7aaf9fb184ffed4e69d1d709f3ec242423dd699014e89ce7eaf99cb225299110b3a6fed4059db89c3bbd05b30262d56dec4bf60bed367f01700f40fde883 SHA512 7c14a15b9b85f777e5151fae82dfbdb44dbfc85ce8f632b7d76727bce79ed7f958f725f39348489bc4659cb5e3b7ab5370e88e33c03277e16ab2f9ff00bb4038
+DIST arpoison-0.7.tar.gz 8458 BLAKE2B b0050aa6f3246fec9fb4db8bbb3f9f5f1d52b5b6c37851f0c6bec8b6c89fabd7f1811ae40a4c81af6eae16761f38fb749d0f2a58311645ef360d798b6ccbbb50 SHA512 d5af078c8e2c64eb721da75b5d6659ca017267f146d0dca7e0f1ba77bfd93a0f56363428c198e9c46537768d3568d813c150bfbc091430fc355a269f9327108f
EBUILD arpoison-0.6-r2.ebuild 777 BLAKE2B c94d7ac7a0ae6afc7472f4e5152d65adadb9868af82e722b7744be7ef674ac4586297d8245dc46ef5fd1b3d33ecd52334f633d8ffa74465cff96962a539d63c2 SHA512 91565961d5cf3148236dd4522ac5343e46eb3bc76dda80d8fc5b35b0d9d5a21cfa1c3716207b580a7fde7127b596295cceb7f14a9b52bbbf67afa0d170b988bc
+EBUILD arpoison-0.7.ebuild 685 BLAKE2B 463d1b2114786f82ef451fa97d62513e8a85e9eb7127e39187d2841fd8c2ab1243740a37614fdb950318dd6f3a8c19fdf42e446193f0ca6dc754730253558d85 SHA512 19c323c2d36dc7797b437ca8304d0181f2aa51f87bee7e04ae95b772c2d999fc1d024d530ca63eea5bb42a3a399825499c6f94d63fb20510683fe01d665ad30c
MISC metadata.xml 358 BLAKE2B 8ef81a7500bfd11eb443af7fdbe30ce89f91875ddd9434367e7eafb73604d13e6702fd34c88bb863bceeeb95822cff1354313d2146117c1ef32166527bd82716 SHA512 9a11704d5314e9ab1a061a179e757146b29c52334511578fe958455d417652c0ab523a58a17580ea6892e528d44b06aa8510293664d78ed01f35e32ef1d7bc18
diff --git a/net-analyzer/arpoison/arpoison-0.7.ebuild b/net-analyzer/arpoison/arpoison-0.7.ebuild
new file mode 100644
index 000000000000..49817cdd9dc7
--- /dev/null
+++ b/net-analyzer/arpoison/arpoison-0.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="A utility to poison ARP caches"
+HOMEPAGE="http://arpoison.sourceforge.net/ http://www.arpoison.net/"
+SRC_URI="https://dev.gentoo.org/~jer/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+RDEPEND="
+ net-libs/libnet:1.1
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+src_compile() {
+ local compile="$(tc-getCC) ${PN}.c -o ${PN} ${CFLAGS} ${LDFLAGS} $("${BROOT}/usr/bin/libnet-config" --cflags --libs)"
+ echo "${compile}"
+ ${compile} || die
+}
+
+src_install() {
+ dosbin arpoison
+ doman arpoison.8
+ dodoc README
+}