summaryrefslogtreecommitdiff
path: root/net-analyzer/fprobe/fprobe-1.1-r6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-10 18:05:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-10 18:05:22 +0000
commit17dcfeba22240edb3c54d96e319edf6c4bc008c3 (patch)
treebf7e044eef048853420208d083f77f7cd820e881 /net-analyzer/fprobe/fprobe-1.1-r6.ebuild
parentf95eeaf7db6ca1bfbb34c05fdad9ed9bb603b1c8 (diff)
gentoo auto-resync : 10:03:2023 - 18:05:22
Diffstat (limited to 'net-analyzer/fprobe/fprobe-1.1-r6.ebuild')
-rw-r--r--net-analyzer/fprobe/fprobe-1.1-r6.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-analyzer/fprobe/fprobe-1.1-r6.ebuild b/net-analyzer/fprobe/fprobe-1.1-r6.ebuild
new file mode 100644
index 000000000000..b873e1f9619b
--- /dev/null
+++ b/net-analyzer/fprobe/fprobe-1.1-r6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="libpcap-based tool to collect network traffic data and emit it as NetFlow flows"
+HOMEPAGE="https://fprobe.sourceforge.net"
+SRC_URI="mirror://sourceforge/fprobe/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="debug messages"
+
+RDEPEND="net-libs/libpcap"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/fprobe-1.1-pidfile-sanity.patch
+ "${FILESDIR}"/fprobe-1.1-setgroups.patch
+)
+
+src_prepare() {
+ default
+
+ # Clang 16, bug #899924
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable messages)
+}
+
+src_install() {
+ default
+
+ docinto contrib
+ dodoc contrib/tg.sh
+
+ newinitd "${FILESDIR}"/init.d-fprobe-r1 fprobe
+ newconfd "${FILESDIR}"/conf.d-fprobe-r1 fprobe
+}