summaryrefslogtreecommitdiff
path: root/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild')
-rw-r--r--net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild41
1 files changed, 17 insertions, 24 deletions
diff --git a/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild b/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
index e3c5413176f4..d02fe4973709 100644
--- a/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
+++ b/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+EAPI=8
-inherit cmake-utils python-single-r1
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit cmake python-single-r1
DESCRIPTION="gnuradio fosphor block (GPU spectrum display)"
HOMEPAGE="https://sdr.osmocom.org/trac/wiki/fosphor"
-if [[ ${PV} == 9999* ]]; then
+if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/osmocom/${PN}.git"
else
@@ -19,18 +20,12 @@ else
KEYWORDS="~amd64 ~x86"
fi
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
LICENSE="GPL-3+"
SLOT="0"
IUSE="glfw qt5"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtopengl:5
- dev-qt/qtwidgets:5
- )
+RDEPEND="
dev-libs/boost:=
dev-libs/log4cpp
media-libs/freetype
@@ -39,16 +34,14 @@ RDEPEND="qt5? (
virtual/opencl
virtual/opengl
${PYTHON_DEPS}
-"
-DEPEND="${RDEPEND}
- dev-lang/swig:0
- dev-util/cppunit
-"
-
-src_prepare() {
- cmake-utils_src_prepare
- default
-}
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-lang/swig:0"
src_configure() {
# tries to run OpenCL test program, but failing doesn't hurt
@@ -60,5 +53,5 @@ src_configure() {
-DENABLE_QT="$(usex qt5)"
-DENABLE_PYTHON=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}