summaryrefslogtreecommitdiff
path: root/net-analyzer/gspoof/gspoof-3.2-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-25 13:01:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-25 13:01:09 +0000
commitecf595717796995cab38a07093dc9597d55d0ea6 (patch)
tree54c2bcea4aafadac2dffe16181af3f0c7dea045e /net-analyzer/gspoof/gspoof-3.2-r3.ebuild
parent50c71de793c37c19d34a68b3af53ba5e7ca51d22 (diff)
gentoo auto-resync : 25:03:2024 - 13:01:08
Diffstat (limited to 'net-analyzer/gspoof/gspoof-3.2-r3.ebuild')
-rw-r--r--net-analyzer/gspoof/gspoof-3.2-r3.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/net-analyzer/gspoof/gspoof-3.2-r3.ebuild b/net-analyzer/gspoof/gspoof-3.2-r3.ebuild
index 0dc610e0e3d7..b44beb880250 100644
--- a/net-analyzer/gspoof/gspoof-3.2-r3.ebuild
+++ b/net-analyzer/gspoof/gspoof-3.2-r3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools desktop
+inherit autotools desktop flag-o-matic
DESCRIPTION="A simple GTK/command line TCP/IP packet generator"
HOMEPAGE="http://gspoof.sourceforge.net/"
@@ -31,6 +31,17 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/861158
+ #
+ # Upstream sourceforge is dead. Software last updated in December 2003.
+ # No bug filed.
+ filter-lto
+
+ default
+}
+
src_compile() {
emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
}