summaryrefslogtreecommitdiff
path: root/net-analyzer/hping/hping-3_pre20141226.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
commit265dbe5dbc14c199299496c6db8fce3f76647015 (patch)
treeab18b5617d138f6684566b619405090989d55a2c /net-analyzer/hping/hping-3_pre20141226.ebuild
parent586819755b4dbfdffdc8a725ab7c0f86095b8489 (diff)
gentoo resync : 21.09.2018
Diffstat (limited to 'net-analyzer/hping/hping-3_pre20141226.ebuild')
-rw-r--r--net-analyzer/hping/hping-3_pre20141226.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-analyzer/hping/hping-3_pre20141226.ebuild b/net-analyzer/hping/hping-3_pre20141226.ebuild
new file mode 100644
index 000000000000..72c3c7249331
--- /dev/null
+++ b/net-analyzer/hping/hping-3_pre20141226.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A ping-like TCP/IP packet assembler/analyzer"
+HOMEPAGE="http://www.hping.org"
+HPING_COMMIT="3547c7691742c6eaa31f8402e0ccbb81387c1b99"
+SRC_URI="https://github.com/antirez/${PN}/archive/${HPING_COMMIT}.zip -> ${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE="tcl"
+
+S=${WORKDIR}/${PN}-${HPING_COMMIT}
+
+DEPEND="
+ net-libs/libpcap
+ tcl? ( dev-lang/tcl:0= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3_pre20051105-libtcl.patch
+ "${FILESDIR}"/${PN}-3_pre20051105-tcl.patch
+ "${FILESDIR}"/${PN}-3_pre20051105-tclsh-proper-escaping.patch
+ "${FILESDIR}"/${PN}-3_pre20141226-compile.patch
+ "${FILESDIR}"/${PN}-3_pre20141226-hping2-2-hping.patch
+ "${FILESDIR}"/${PN}-3_pre20141226-indent.patch
+ "${FILESDIR}"/${PN}-3_pre20141226-pcap-bpf.patch
+ "${FILESDIR}"/${PN}-3_pre20141226-scan-overflow.patch
+ "${FILESDIR}"/${PN}-3_pre20141226-unused-but-set.patch
+)
+
+src_configure() {
+ tc-export CC
+
+ # Not an autotools type configure:
+ sh configure $(usex tcl '' --no-tcl) || die
+}
+
+src_compile() {
+ emake \
+ DEBUG="" \
+ "CFLAGS=${CFLAGS}" \
+ "AR=$(tc-getAR)" \
+ "RANLIB=$(tc-getRANLIB)" \
+ "LIBDIR=$(get_libdir)"
+}
+
+src_install () {
+ dosbin hping3
+ dosym hping3 /usr/sbin/hping
+ dosym hping3 /usr/sbin/hping2
+
+ newman docs/hping3.8 hping.8
+
+ dodoc AUTHORS BUGS CHANGES INSTALL NEWS README TODO
+}