summaryrefslogtreecommitdiff
path: root/net-analyzer/ifstatus/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/ifstatus/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/ifstatus/files')
-rw-r--r--net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc43.patch10
-rw-r--r--net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc6.patch14
-rw-r--r--net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch22
3 files changed, 46 insertions, 0 deletions
diff --git a/net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc43.patch b/net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc43.patch
new file mode 100644
index 000000000000..27111d7576f4
--- /dev/null
+++ b/net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc43.patch
@@ -0,0 +1,10 @@
+--- a/Main.h
++++ b/Main.h
+@@ -38,6 +38,7 @@
+ #include <unistd.h>
+ #include <string.h>
+ #include <curses.h>
++#include <stdlib.h>
+
+ #include <sys/time.h>
+ #include <sys/types.h>
diff --git a/net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc6.patch b/net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc6.patch
new file mode 100644
index 000000000000..760a09fbf2c6
--- /dev/null
+++ b/net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc6.patch
@@ -0,0 +1,14 @@
+--- a/Interface.h
++++ b/Interface.h
+@@ -57,7 +57,11 @@
+
+ InterfaceData & operator=(InterfaceData & rInterfaceData);
+ InterfaceData operator-(InterfaceData & rInterfaceData);
+
++#if __cplusplus >= 201103L
++ InterfaceData & operator=(InterfaceData && rInterfaceData) = default;
++ InterfaceData(const InterfaceData&) = default;
++#endif
+ private:
+
+ unsigned long long m_ullReceived[eTotalTypes];
diff --git a/net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch b/net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch
new file mode 100644
index 000000000000..e2c14e6add71
--- /dev/null
+++ b/net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch
@@ -0,0 +1,22 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,9 +1,7 @@
+ # Makefile for IFStatus
+ # Gabriel Montenegro
+
+-GCC = g++
+-LDFLAGS = -lncurses
+-CFLAGS = -O2 -Wall
++LDLIBS = $(shell $(PKG_CONFIG) --libs ncurses)
+
+ BIN = ifstatus
+ OBJ = BorderDecorator.o\
+@@ -30,7 +28,7 @@
+ all : ifstatus printdone
+
+ ifstatus : $(OBJ)
+- $(GCC) $(CFLAGS) $(LDFLAGS) $^ -o $@
++ $(LINK.cc) $^ $(LDLIBS) -o $@
+
+ printdone:
+ @if [ -e "./${BIN}" ]; then echo "Compiled.."; else echo "Error compiling!"; fi