summaryrefslogtreecommitdiff
path: root/net-analyzer/ifstatus/ifstatus-1.1.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/ifstatus/ifstatus-1.1.0-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/ifstatus/ifstatus-1.1.0-r2.ebuild')
-rw-r--r--net-analyzer/ifstatus/ifstatus-1.1.0-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-analyzer/ifstatus/ifstatus-1.1.0-r2.ebuild b/net-analyzer/ifstatus/ifstatus-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..cc2baff02f50
--- /dev/null
+++ b/net-analyzer/ifstatus/ifstatus-1.1.0-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils toolchain-funcs
+
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+DESCRIPTION="A simple CLI program for displaying network statistics in real time"
+HOMEPAGE="http://ifstatus.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-v${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND=">=sys-libs/ncurses-4.2:0="
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gcc43.patch"
+ "${FILESDIR}/${P}-tinfo.patch"
+ "${FILESDIR}/${P}-gcc6.patch"
+)
+
+src_prepare() {
+ default
+ tc-export CXX PKG_CONFIG
+}
+
+src_install() {
+ dobin ifstatus
+ dodoc AUTHORS README
+}
+
+pkg_postinst() {
+ elog "You may want to configure ~/.ifstatus/ifstatus.cfg"
+ elog "before running ifstatus. For example, you may add"
+ elog "Interfaces = eth0 there. Read the README file for"
+ elog "more information."
+}