summaryrefslogtreecommitdiff
path: root/net-analyzer/ike-scan/ike-scan-1.9-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/ike-scan/ike-scan-1.9-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/ike-scan/ike-scan-1.9-r2.ebuild')
-rw-r--r--net-analyzer/ike-scan/ike-scan-1.9-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/ike-scan/ike-scan-1.9-r2.ebuild b/net-analyzer/ike-scan/ike-scan-1.9-r2.ebuild
new file mode 100644
index 000000000000..6fa3edca229f
--- /dev/null
+++ b/net-analyzer/ike-scan/ike-scan-1.9-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="A utility for finding, fingerprinting and testing IKE VPN servers"
+HOMEPAGE="http://www.nta-monitor.com/ike-scan/"
+SRC_URI="http://www.nta-monitor.com/ike-scan/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="libressl ssl"
+
+DEPEND="ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+)"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Fix buffer overflow, bug #277556
+ sed \
+ -e "/MAXLINE/s:255:511:g" \
+ -i ike-scan.h || die
+}
+
+src_configure() {
+ # --disable-lookup prevents ike-scan from phoning home
+ # for more information, please see bug 157507
+ econf $(use_with ssl openssl) --disable-lookup
+}
+
+src_install() {
+ default
+ dodoc udp-backoff-fingerprinting-paper.txt
+}