summaryrefslogtreecommitdiff
path: root/net-analyzer/iptraf-ng/iptraf-ng-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /net-analyzer/iptraf-ng/iptraf-ng-9999.ebuild
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'net-analyzer/iptraf-ng/iptraf-ng-9999.ebuild')
-rw-r--r--net-analyzer/iptraf-ng/iptraf-ng-9999.ebuild20
1 files changed, 8 insertions, 12 deletions
diff --git a/net-analyzer/iptraf-ng/iptraf-ng-9999.ebuild b/net-analyzer/iptraf-ng/iptraf-ng-9999.ebuild
index 284d4bb322e4..4c2ce0db62b9 100644
--- a/net-analyzer/iptraf-ng/iptraf-ng-9999.ebuild
+++ b/net-analyzer/iptraf-ng/iptraf-ng-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3 toolchain-funcs
+inherit flag-o-matic git-r3 toolchain-funcs
DESCRIPTION="A console-based network monitoring utility"
HOMEPAGE="https://github.com/iptraf-ng/iptraf-ng"
@@ -13,8 +13,6 @@ SLOT="0"
KEYWORDS=""
IUSE="doc"
-RESTRICT="test"
-
RDEPEND="
>=sys-libs/ncurses-5.7-r7:0=
"
@@ -23,10 +21,9 @@ DEPEND="
virtual/os-headers
!net-analyzer/iptraf
"
+RESTRICT="test"
src_prepare() {
- default
-
sed -i \
-e '/^CC =/d' \
-e '/^CFLAGS/s:= -g -O2:+= :' \
@@ -40,15 +37,14 @@ src_prepare() {
-e 's|rvnamed|&-ng|g' \
-e 's|RVNAMED|&-NG|g' \
src/*.8 || die
-}
-# configure does not do very much we do not already control
-src_configure() { :; }
+ default
+}
-src_compile() {
+src_configure() {
+ # The configure script does not do very much we do not already control
+ append-cppflags '-DLOCKDIR=\"/run/lock/iptraf-ng\"'
tc-export CC
- CFLAGS+=' -DLOCKDIR=\"/run/lock/iptraf-ng\"'
- default
}
src_install() {
@@ -59,7 +55,7 @@ src_install() {
if use doc; then
docinto html
- dodoc -r Documentation
+ dodoc -r Documentation/*
fi
keepdir /var/{lib,log}/iptraf-ng #376157