summaryrefslogtreecommitdiff
path: root/net-analyzer/labrea/labrea-2.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/labrea/labrea-2.5-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/labrea/labrea-2.5-r2.ebuild')
-rw-r--r--net-analyzer/labrea/labrea-2.5-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/labrea/labrea-2.5-r2.ebuild b/net-analyzer/labrea/labrea-2.5-r2.ebuild
new file mode 100644
index 000000000000..cdbff85668a0
--- /dev/null
+++ b/net-analyzer/labrea/labrea-2.5-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="'Sticky' Honeypot and IDS"
+HOMEPAGE="http://labrea.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-stable-1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+DEPEND="net-libs/libpcap
+ >=dev-libs/libdnet-1.7"
+RDEPEND="${DEPEND}"
+
+MY_P="${P}-stable-1"
+S=${WORKDIR}/${MY_P}
+
+DOCS=( AUTHORS ChangeLog README TODO NEWS )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-stable-1-incdir.patch
+ eautoreconf
+}
+
+src_install() {
+ default
+ newdoc INSTALL README.first
+}
+
+pkg_postinst() {
+ ewarn "Before using this package READ the INSTALL and README"
+ ewarn "as the author states that it can cause serious problems on your network."
+
+}