summaryrefslogtreecommitdiff
path: root/net-analyzer/nagios-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-15 03:02:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-15 03:02:36 +0000
commit57d1fe5ae0c56e604db5d29bf7b62d685c42e043 (patch)
treebc1bdf3c531b7b4cef73b051dbb3cd439dee4a39 /net-analyzer/nagios-plugins
parentd3c7d3e5f9607edef1a795ccc502ab3eb3121165 (diff)
gentoo auto-resync : 15:11:2024 - 03:02:36
Diffstat (limited to 'net-analyzer/nagios-plugins')
-rw-r--r--net-analyzer/nagios-plugins/Manifest2
-rw-r--r--net-analyzer/nagios-plugins/nagios-plugins-2.4.12.ebuild121
2 files changed, 123 insertions, 0 deletions
diff --git a/net-analyzer/nagios-plugins/Manifest b/net-analyzer/nagios-plugins/Manifest
index 7325c4457eb6..9b0fd2353070 100644
--- a/net-analyzer/nagios-plugins/Manifest
+++ b/net-analyzer/nagios-plugins/Manifest
@@ -1,3 +1,5 @@
+DIST nagios-plugins-2.4.12.tar.gz 2752829 BLAKE2B b72b9350e9c72c9cbe0cbca3effce16ec753887945455a1ac47975105e68f516923020cc88ee42da0c8cd815fe841a82ff5053c3ba5688888bec7be12c08fb8c SHA512 fbff697d0cea1cbeb83737f240a42c00e18bf443b8af303b5d7f7f735eb6faa5305d8740fb27472876dc1398735204e0d7a0e5863c2064ec2a37541253f91502
DIST nagios-plugins-2.4.6.tar.gz 2751770 BLAKE2B a85da8eaa8d926e2ccae3451d9faa680b75ebd736ba1306c69e7d3b2b8749787743dd6e26013d3a72fba12ef49fdf635c60052791fab558eb49c379bdbb6bac7 SHA512 f2a12a5b6a70849d7233debd1ca95667df981d3627287e3b8813d8fd709c4f4a26cf2128851837f33e0df3132132a4f891edef90e220bc16b1a6351d514faa43
+EBUILD nagios-plugins-2.4.12.ebuild 3281 BLAKE2B 6320c2af338658866447f4b23fe0cc786076619e6fb2746bfb680ed4d84026f687517e01696c3e741e9a8bd0ba3bd1fee3b77975774bf6aff56b1049e8ffa512 SHA512 787f749cd704763c756783219c56a041e67b4240cc89617f0f0a56ebc0fde48ae6d00856c3d58e9a465eb2dda9fd58b22171c2552a9305e85cc6ded41e52a6d2
EBUILD nagios-plugins-2.4.6.ebuild 3277 BLAKE2B a11fda621ca3b455586550f55704ff0eb0880cf244d566c5cb7cf76e011a22358d3c1bad8994bbbf754a4b3d33239790f262800e353dbf2a6059ce43423c623a SHA512 7a57cb998ed1b1021a008c5f54a9233fab73058b86547d3e18c610aa528cab2899b90270a232d4d328e4ce2b3124dc00c49d6f636d47f1326854eaf937715a0b
MISC metadata.xml 1569 BLAKE2B 4ebfd50870acac360fa2708dba05d3ea925e7d93444da82ca93067b4c8eeb177e8055cba4d12d690c8d9e1f5448447d6bf94a5991a09d0f4a2ee6126338bb707 SHA512 fffa8c7bc36e0cfd4ca35ab8c8f327749e0c6744a9567d9a6c88180c178a2a5bbf67df31b289d9319bc725d2fab4433a9d00443a87d0950777ed0c05031da193
diff --git a/net-analyzer/nagios-plugins/nagios-plugins-2.4.12.ebuild b/net-analyzer/nagios-plugins/nagios-plugins-2.4.12.ebuild
new file mode 100644
index 000000000000..841c473ee4dc
--- /dev/null
+++ b/net-analyzer/nagios-plugins/nagios-plugins-2.4.12.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Official plugins for Nagios"
+HOMEPAGE="https://nagios-plugins.org/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/release-${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ipv6 ldap mysql nagios-dns nagios-ping nagios-game postgres radius samba selinux snmp ssh +ssl"
+
+# Most of the plugins use automagic dependencies, i.e. the plugin will
+# get built if the binary it uses is installed. For example, check_snmp
+# will be built only if snmpget from net-analyzer/net-snmp[-minimal] is
+# installed. End result: most of our runtime dependencies are required
+# at build time as well.
+AUTOMAGIC_DEPEND="
+ nagios-dns? ( net-dns/bind-tools )
+ nagios-game? ( games-util/qstat )
+ nagios-ping? ( net-analyzer/fping )
+ samba? ( net-fs/samba )
+ ssh? ( virtual/openssh )
+ snmp? ( dev-perl/Net-SNMP
+ net-analyzer/net-snmp[-minimal] )"
+
+# Perl really needs to run during the build...
+BDEPEND="${AUTOMAGIC_DEPEND}
+ dev-lang/perl"
+
+DEPEND="
+ ldap? ( net-nds/openldap:= )
+ mysql? ( dev-db/mysql-connector-c:= )
+ postgres? ( dev-db/postgresql:* )
+ ssl? (
+ dev-libs/openssl:0=
+ )
+ radius? ( net-dialup/freeradius-client )"
+
+# Basically everything in net-analyzer/monitoring-plugins collides with
+# nagios-plugins. Perl (from BDEPEND) is needed at runtime, too.
+RDEPEND="${BDEPEND}
+ ${DEPEND}
+ !net-analyzer/monitoring-plugins
+ selinux? ( sec-policy/selinux-nagios )"
+
+# At least one test is interactive.
+RESTRICT="test"
+
+DOCS=(
+ ACKNOWLEDGEMENTS
+ AUTHORS
+ CODING
+ ChangeLog
+ FAQ
+ NEWS
+ README
+ REQUIREMENTS
+ SUPPORT
+ THANKS
+)
+
+# These all come from gnulib and the ./configure checks are working as
+# intended when the functions aren't present. Bugs 907755 and 924341.
+QA_CONFIG_IMPL_DECL_SKIP=(
+ statvfs64
+ re_set_syntax
+ re_compile_pattern
+ re_search
+ re_match
+)
+
+src_prepare() {
+ default
+
+ # Fix the path to our perl interpreter
+ sed -i -e "1s:/usr/local/bin/perl:/usr/bin/perl:" \
+ "${S}"/plugins-scripts/*.pl \
+ || die 'failed to fix perl interpreter path'
+}
+
+src_configure() {
+ # Use an array to prevent econf from mangling the ping args.
+ local myconf=()
+
+ if use ssl; then
+ myconf+=( $(use_with ssl openssl /usr) )
+ else
+ myconf+=( --without-openssl )
+ myconf+=( --without-gnutls )
+ fi
+
+ # The autodetection for these two commands can hang if localhost is
+ # down or ICMP traffic is filtered (bug #468296). But also the path
+ # likes to move around on us (bug #883765).
+ myconf+=( --with-ping-command="$(command -v ping) -n -U -w %d -c %d %s" )
+
+ if use ipv6; then
+ myconf+=( --with-ping6-command="$(command -v ping6) -n -U -w %d -c %d %s" )
+ fi
+
+ econf \
+ $(use_with mysql) \
+ $(use_with ipv6) \
+ $(use_with ldap) \
+ $(use_with postgres pgsql /usr) \
+ $(use_with radius) \
+ "${myconf[@]}" \
+ --libexecdir="/usr/$(get_libdir)/nagios/plugins" \
+ --sysconfdir="/etc/nagios"
+}
+
+pkg_postinst() {
+ elog "This ebuild has a number of USE flags that determine what you"
+ elog "are able to monitor. Depending on what you want to monitor, some"
+ elog "or all of these USE flags need to be set."
+ elog
+ elog "The plugins are installed in ${ROOT}/usr/$(get_libdir)/nagios/plugins"
+}