summaryrefslogtreecommitdiff
path: root/net-analyzer/nagios-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /net-analyzer/nagios-plugins
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'net-analyzer/nagios-plugins')
-rw-r--r--net-analyzer/nagios-plugins/Manifest1
-rw-r--r--net-analyzer/nagios-plugins/nagios-plugins-2.2.1-r3.ebuild118
2 files changed, 119 insertions, 0 deletions
diff --git a/net-analyzer/nagios-plugins/Manifest b/net-analyzer/nagios-plugins/Manifest
index c4bd449450d8..374495ec126f 100644
--- a/net-analyzer/nagios-plugins/Manifest
+++ b/net-analyzer/nagios-plugins/Manifest
@@ -3,4 +3,5 @@ DIST nagios-plugins-2.0.3.tar.gz 2659772 BLAKE2B d4deccf04458daccde5fbe7e6c65928
DIST nagios-plugins-2.2.1.tar.gz 2728818 BLAKE2B ea89862935491d9c31403a36712d39557fa8e90dc2306e027531e974933cd13cc6b55ebfdd7dfc7541d6458741aaf57714df57fdddc92049001a59f0ffb6413a SHA512 6ffe313a56a305b382f62abc0f0958d7078f9050e1340f30721d6e6f71944b57b1650e90e6835c35dd7c9f3f4b4cee9f235b8382b0811db30b3729daaafc9bc3
EBUILD nagios-plugins-2.0.3-r2.ebuild 2828 BLAKE2B 2581655bd322f74c6253811b6a10de420c5f1c90677d87d5f344f4939d45b00d394fe8b026b44ed9bf76024d18ef67d4f7ab222e6fa75e72d88e7c4f44eae94a SHA512 cabe19f142006c4d104721361c2c58fc7a103717041050a21bc21b47adb6702bf05c77f1ed8b063f74b11a59a2dd1120d8478e5b1d803636aeb9f1ae92c2ae91
EBUILD nagios-plugins-2.2.1-r2.ebuild 3109 BLAKE2B fb9958b01df2993cf3f2f95c50996f94b30e9238a39e116dd857255c60bb4d516781171041d8070a50ffc7526766d24b0331c4f93302d875e17775043b4f84ab SHA512 a7080b7c27013958a97a9125ba11bfa93be6402dbe8a8667b80f236bf3364e994b44815bb6ace6e24e08a0f9c0f90f96f47ca2d71403152c444b4b5afd064249
+EBUILD nagios-plugins-2.2.1-r3.ebuild 3126 BLAKE2B 21e3131fb9dcdeaffd3779dd8d247e15c88228956abfeb33ac39b9d8a9d42d1d734d8a9a7b7a08a91f622975c799fbe29045aaef69cfac24d59ce60a5f9b3109 SHA512 d60932357aca2aa80533314ef6db485b634aa1a1fb8419a8d4c68a1ed518ceb663b90a875eb9b1c8e51ec5bda585108bdf7f31c9f8f67a9381710e2dd2dab50f
MISC metadata.xml 1430 BLAKE2B 63a889dc51085a41a5dec4b6c32e6262ff59fdb1413699736d6332a75406749551b1c82d62a2662f4d7935c46a4bc3b51e0ca7e3b070656163fb0b6fc69c742e SHA512 d6cbc6820de52e1ed471b97a6c592af72474db492204594314eebb656b8abe89a01667a7bbb621418fd393aeacb28e9a10c5749de7ace67dd15119f701019e72
diff --git a/net-analyzer/nagios-plugins/nagios-plugins-2.2.1-r3.ebuild b/net-analyzer/nagios-plugins/nagios-plugins-2.2.1-r3.ebuild
new file mode 100644
index 000000000000..6c36a0214b5b
--- /dev/null
+++ b/net-analyzer/nagios-plugins/nagios-plugins-2.2.1-r3.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit user
+
+DESCRIPTION="Official plugins for Nagios"
+HOMEPAGE="http://nagios-plugins.org/"
+SRC_URI="http://nagios-plugins.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ipv6 ldap libressl mysql nagios-dns nagios-ping nagios-game postgres radius samba selinux snmp ssh +ssl"
+
+# Most of the plugins use automagic dependencies, i.e. the plugin will
+# get built if the binary it uses is installed. For example, check_snmp
+# will be built only if snmpget from net-analyzer/net-snmp[-minimal] is
+# installed. End result: most of our runtime dependencies are required
+# at build time as well.
+#
+# REAL_DEPEND contains the dependencies that are actually needed to
+# build. DEPEND contains those plus the automagic dependencies.
+#
+REAL_DEPEND="dev-lang/perl
+ ldap? ( net-nds/openldap )
+ mysql? ( dev-db/mysql-connector-c )
+ postgres? ( dev-db/postgresql:* )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ )
+ radius? ( net-dialup/freeradius-client )"
+
+DEPEND="${REAL_DEPEND}
+ nagios-dns? ( net-dns/bind-tools )
+ nagios-game? ( games-util/qstat )
+ nagios-ping? ( net-analyzer/fping )
+ samba? ( net-fs/samba )
+ ssh? ( net-misc/openssh )
+ snmp? ( dev-perl/Net-SNMP
+ net-analyzer/net-snmp[-minimal] )"
+
+# Basically everything collides with nagios-plugins.
+RDEPEND="${DEPEND}
+ !net-analyzer/monitoring-plugins
+ selinux? ( sec-policy/selinux-nagios )"
+
+# At least one test is interactive.
+RESTRICT="test"
+
+DOCS=(
+ ACKNOWLEDGEMENTS
+ AUTHORS
+ CODING
+ ChangeLog
+ FAQ
+ NEWS
+ README
+ REQUIREMENTS
+ SUPPORT
+ THANKS
+)
+
+PATCHES=( "${FILESDIR}/define-own-mysql-port-constant.patch" )
+
+src_prepare() {
+ default
+
+ # Fix the path to our perl interpreter
+ sed -i -e "1s:/usr/local/bin/perl:/usr/bin/perl:" \
+ "${S}"/plugins-scripts/*.pl \
+ || die 'failed to fix perl interpreter path'
+}
+
+src_configure() {
+ # Use an array to prevent econf from mangling the ping args.
+ local myconf=()
+
+ if use ssl; then
+ myconf+=( $(use_with ssl openssl /usr) )
+ else
+ myconf+=( --without-openssl )
+ myconf+=( --without-gnutls )
+ fi
+
+ # The autodetection for these two commands can hang if localhost is
+ # down or ICMP traffic is filtered. Bug #468296.
+ myconf+=( --with-ping-command="/bin/ping -n -U -w %d -c %d %s" )
+
+ if use ipv6; then
+ myconf+=( --with-ping6-command="/bin/ping6 -n -U -w %d -c %d %s" )
+ fi
+
+ econf \
+ $(use_with mysql) \
+ $(use_with ipv6) \
+ $(use_with ldap) \
+ $(use_with postgres pgsql /usr) \
+ $(use_with radius) \
+ "${myconf[@]}" \
+ --libexecdir="/usr/$(get_libdir)/nagios/plugins" \
+ --sysconfdir="/etc/nagios"
+}
+
+pkg_preinst() {
+ enewgroup nagios
+ enewuser nagios -1 /bin/bash /var/nagios/home nagios
+}
+
+pkg_postinst() {
+ elog "This ebuild has a number of USE flags that determine what you"
+ elog "are able to monitor. Depending on what you want to monitor, some"
+ elog "or all of these USE flags need to be set."
+ elog
+ elog "The plugins are installed in ${ROOT}usr/$(get_libdir)/nagios/plugins"
+}