summaryrefslogtreecommitdiff
path: root/net-analyzer/ndsad/ndsad-1.33-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /net-analyzer/ndsad/ndsad-1.33-r2.ebuild
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'net-analyzer/ndsad/ndsad-1.33-r2.ebuild')
-rw-r--r--net-analyzer/ndsad/ndsad-1.33-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-analyzer/ndsad/ndsad-1.33-r2.ebuild b/net-analyzer/ndsad/ndsad-1.33-r2.ebuild
new file mode 100644
index 000000000000..e7f9a919a4a4
--- /dev/null
+++ b/net-analyzer/ndsad/ndsad-1.33-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Cisco netflow probe from libpcap, ULOG, tee/divert sources"
+HOMEPAGE="https://sourceforge.net/projects/ndsad"
+SRC_URI="mirror://sourceforge/ndsad/ndsad-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="
+ >=net-libs/libpcap-0.8
+"
+RDEPEND="
+ ${DEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-conf_path.patch
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-getpid.patch
+ "${FILESDIR}"/${P}-log-path.patch
+ "${FILESDIR}"/${P}-strncpy-overflow.patch
+)
+DOCS=( ChangeLog AUTHORS README )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ doman ndsad.conf.5
+
+ insinto /etc
+ newins ndsad.conf ndsad.conf
+
+ newinitd "${FILESDIR}"/ndsad.init ndsad
+ newconfd "${FILESDIR}"/ndsad.conf.d ndsad
+}