summaryrefslogtreecommitdiff
path: root/net-analyzer/netdata/netdata-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /net-analyzer/netdata/netdata-9999.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'net-analyzer/netdata/netdata-9999.ebuild')
-rw-r--r--net-analyzer/netdata/netdata-9999.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/net-analyzer/netdata/netdata-9999.ebuild b/net-analyzer/netdata/netdata-9999.ebuild
index 256ee9f3417a..64c8c68c5aa7 100644
--- a/net-analyzer/netdata/netdata-9999.ebuild
+++ b/net-analyzer/netdata/netdata-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -10,7 +10,8 @@ if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/netdata/${PN}.git"
inherit git-r3
else
- SRC_URI="https://github.com/netdata/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/netdata/${PN}/releases/download/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-v${PV}"
KEYWORDS="~amd64 ~x86"
fi
@@ -19,7 +20,7 @@ HOMEPAGE="https://github.com/netdata/netdata https://my-netdata.io/"
LICENSE="GPL-3+ MIT BSD"
SLOT="0"
-IUSE="caps +compression cpu_flags_x86_sse2 cups +dbengine ipmi +jsonc kinesis +lto mongodb mysql nfacct nodejs postgres prometheus +python tor xen"
+IUSE="caps cloud +compression cpu_flags_x86_sse2 cups +dbengine ipmi +jsonc kinesis +lto mongodb mysql nfacct nodejs postgres prometheus +python tor xen"
REQUIRED_USE="
mysql? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
@@ -91,11 +92,11 @@ src_prepare() {
}
src_configure() {
- # --disable-cloud: https://github.com/netdata/netdata/issues/8961
econf \
--localstatedir="${EPREFIX}"/var \
--with-user=netdata \
- --disable-cloud \
+ $(use_enable cloud) \
+ $(use_with cloud aclk-ng) \
$(use_enable jsonc) \
$(use_enable cups plugin-cups) \
$(use_enable dbengine) \
@@ -110,6 +111,11 @@ src_configure() {
$(use_with compression zlib)
}
+src_compile() {
+ emake clean
+ default
+}
+
src_install() {
default