summaryrefslogtreecommitdiff
path: root/net-analyzer/netpipe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/netpipe
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/netpipe')
-rw-r--r--net-analyzer/netpipe/Manifest4
-rw-r--r--net-analyzer/netpipe/files/netpipe-3.7.2-fix-makefile.patch13
-rw-r--r--net-analyzer/netpipe/metadata.xml19
-rw-r--r--net-analyzer/netpipe/netpipe-3.7.2.ebuild44
4 files changed, 80 insertions, 0 deletions
diff --git a/net-analyzer/netpipe/Manifest b/net-analyzer/netpipe/Manifest
new file mode 100644
index 000000000000..da7622877da1
--- /dev/null
+++ b/net-analyzer/netpipe/Manifest
@@ -0,0 +1,4 @@
+AUX netpipe-3.7.2-fix-makefile.patch 316 SHA256 427d959549b2382154766a9b9b96e0910bb1bb0f9800b4a8fa30faf2c96d38af SHA512 5d31cfd8e4007cb0bf0fd5e921c92bfb8f8a1342176091fcd98d35a41a0dfef4125073ff309df1cc6e8682099ce08bfc521bbde900978578dddcc5507482b07b WHIRLPOOL 55201d54da394ed66df84312c3936aa1818448340230d3abe03418edda2975fa44182069341b59c400734e556d5055d81c112148aa325f85a5a4e7ca332bdb72
+DIST NetPIPE-3.7.2.tar.gz 400248 SHA256 13dac884ff52951636f651c421f5ff4a853218a95aa28a4a852402ee385a2ab8 SHA512 158c24665bcc55144452c2aeff067e0d853ffca1ecd130d52c3ea7d4068c53e81f9a1133d0cca847d28f597f68b20f01e79811f81ab1396dd18ba2eaaf691430 WHIRLPOOL 33b22df3075ed57e3e77713ee16f7de3293f7795788afb4ae252ffebe427041f38940311099e03488f5628584ea77a6f1224160b0042241902cd91ae69b5f74d
+EBUILD netpipe-3.7.2.ebuild 794 SHA256 8a58a6fbcd986e39a463b8ad9f526b8cf1e3d52c6f435bafafc1227679555c9b SHA512 a7a232057fdf359bb9838b29574f5c1af4ee9389998253ef1920628fe584e84dbcaa0014d3aa60d44aba55ec50747e0ff989f360506b11449cb0aa3054130ebe WHIRLPOOL 3cc47848536aa4d7d4d237266573929c93cca730c41de3a5eb0c94b6029848353363797274a82e616fecd6dba68f32a28a9a93b5e89933eed0e084723c244917
+MISC metadata.xml 907 SHA256 8d1120316cb7f77b97d0fab0005cdc23130c3d78d1282dae93a156e93bd9c4b6 SHA512 1363771cfcc0a9065be517ede4c7a780add4dac4567db5c8c39b4a4e6860718977db864bbae6efc0b60f8e69aaf9bfbd3eec4cd8ecdff45dfdafb03d16247903 WHIRLPOOL a0e202ba0fe417d0d30a9a61fca09c38924d2c893fc505e61206d3e1b67f3056e99a4daa98816326b39459490d6959e6b1f6f83597f05bec03816fa009982d86
diff --git a/net-analyzer/netpipe/files/netpipe-3.7.2-fix-makefile.patch b/net-analyzer/netpipe/files/netpipe-3.7.2-fix-makefile.patch
new file mode 100644
index 000000000000..f5c61737f7ae
--- /dev/null
+++ b/net-analyzer/netpipe/files/netpipe-3.7.2-fix-makefile.patch
@@ -0,0 +1,13 @@
+diff --git a/makefile b/makefile
+index 16f9052..3ada81f 100644
+--- a/makefile
++++ b/makefile
+@@ -21,8 +21,6 @@
+ #
+ ########################################################################
+
+-CC = cc
+-CFLAGS = -O -g
+ SRC = ./src
+
+ # For MPI, mpicc will set up the proper include and library paths
diff --git a/net-analyzer/netpipe/metadata.xml b/net-analyzer/netpipe/metadata.xml
new file mode 100644
index 000000000000..fd15de965046
--- /dev/null
+++ b/net-analyzer/netpipe/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <longdescription lang="en">
+ NetPIPE is a protocol independent performance tool that visually
+ represents the network performance under a variety of conditions.
+ It performs simple ping-pong tests, bouncing messages of increasing
+ size between two processes, whether across a network or within an
+ SMP system. Message sizes are chosen at regular intervals, and with
+ slight perturbations, to provide a complete test of the communication
+ system. Each data point involves many ping-pong tests to provide an
+ accurate timing. Latencies are calculated by dividing the round
+ trip time in half for small messages ( less 64 Bytes ).
+ </longdescription>
+</pkgmetadata>
diff --git a/net-analyzer/netpipe/netpipe-3.7.2.ebuild b/net-analyzer/netpipe/netpipe-3.7.2.ebuild
new file mode 100644
index 000000000000..894cf55c72a7
--- /dev/null
+++ b/net-analyzer/netpipe/netpipe-3.7.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+MY_PN=NetPIPE
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="network protocol independent performance evaluator"
+HOMEPAGE="http://bitspjoule.org/netpipe/"
+SRC_URI="http://bitspjoule.org/netpipe/code/${MY_P}.tar.gz"
+LICENSE="GPL-1+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="ipv6"
+
+DOCS=(
+ bin/feplot
+ bin/geplot
+ bin/nplaunch
+ dox/README
+ dox/netpipe_paper.ps
+ dox/np_cluster2002.pdf
+ dox/np_euro.pdf
+ )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-makefile.patch
+ )
+
+S="${WORKDIR}"/${MY_P}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" memcpy tcp $(usex ipv6 tcp6 '')
+}
+
+src_install() {
+ dobin NPmemcpy NPtcp
+ use ipv6 && dobin NPtcp6
+ doman dox/netpipe.1
+ einstalldocs
+}