summaryrefslogtreecommitdiff
path: root/net-analyzer/netselect/netselect-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /net-analyzer/netselect/netselect-9999.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'net-analyzer/netselect/netselect-9999.ebuild')
-rw-r--r--net-analyzer/netselect/netselect-9999.ebuild38
1 files changed, 22 insertions, 16 deletions
diff --git a/net-analyzer/netselect/netselect-9999.ebuild b/net-analyzer/netselect/netselect-9999.ebuild
index c41a3b0d656e..7fee270c477b 100644
--- a/net-analyzer/netselect/netselect-9999.ebuild
+++ b/net-analyzer/netselect/netselect-9999.ebuild
@@ -1,21 +1,18 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3 toolchain-funcs
+
+inherit fcaps git-r3 toolchain-funcs
DESCRIPTION="Ultrafast implementation of ping"
HOMEPAGE="http://apenwarr.ca/netselect/"
-EGIT_REPO_URI="
- https://github.com/apenwarr/${PN}
-"
-SRC_URI="
- ipv6? ( https://dev.gentoo.org/~jer/${PN}-0.4-ipv6.patch.xz )
-"
+EGIT_REPO_URI="https://github.com/apenwarr/${PN}"
+SRC_URI="ipv6? ( https://dev.gentoo.org/~jer/${PN}-0.4-ipv6.patch.xz )"
+S="${WORKDIR}/${PN}-${P}"
LICENSE="BSD"
SLOT="0"
-KEYWORDS=""
IUSE="ipv6"
PATCHES=(
@@ -23,15 +20,25 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.4-flags.patch
)
+DOCS=( HISTORY README )
+
+FILECAPS=( -g wheel cap_net_raw usr/bin/netselect )
+
src_unpack() {
use ipv6 && unpack ${A}
git-r3_src_unpack
}
src_prepare() {
- use ipv6 && PATCHES+=( "${WORKDIR}"/${PN}-0.4-ipv6.patch )
+ use ipv6 && eapply "${WORKDIR}"/${PN}-0.4-ipv6.patch
default
+
+ # Don't warn about "root privileges required" when running as
+ # an unprivileged user with filecaps
+ if ! use prefix && use filecaps; then
+ sed -i -e '/if (geteuid () != 0)/,+2d' "${S}"/netselect.c || die
+ fi
}
src_compile() {
@@ -41,12 +48,11 @@ src_compile() {
src_install() {
dobin netselect
- if ! use prefix ; then
- fowners root:wheel /usr/bin/netselect
- fperms 4711 /usr/bin/netselect
- fi
-
- dodoc HISTORY README
+ einstalldocs
doman netselect.1
}
+
+pkg_postinst() {
+ ! use prefix && fcaps_pkg_postinst
+}